WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#50359 closed task (blessed) (fixed)

Twenty Twenty and Twenty Nineteen version bumps for 5.4.2 release

Reported by: ianbelanger Owned by: ianbelanger
Milestone: 5.4.3 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch fixed-major
Focuses: Cc:

Description

This is for the version bumps of Twenty Twenty and Twenty Nineteen for the 5.4.2 release.

Attachments (1)

50359.diff (6.1 KB) - added by ianbelanger 6 months ago.
Version bump

Download all attachments as: .zip

Change History (5)

@ianbelanger
6 months ago

Version bump

#1 @ianbelanger
6 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 47952:

Bundled Themes: Twenty Twenty and Twenty Nineteen version bump.

We are releasing new versions of Twenty Twenty & Twenty Nineteen today thus we need to bump the version.

Props ianbelanger.
Fixes #50359.

#2 @ocean90
6 months ago

@ianbelanger Version bumps for themes must be backported to the branches as well.
Now, WordPress 5.4.2 is still shipping Twenty Twenty with a style.css declaring version 1.2 (while it has all the changes of 1.3 and 1.4) and causing an update notice. Same for Twenty Nineteen any maybe other themes?

#3 @ianbelanger
6 months ago

  • Keywords fixed-major added; commit removed
  • Milestone changed from 5.4.2 to 5.4.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks for the heads up @ocean90. As a Themes Committer I do not have the ability to backport, so if a Core Committer could backport this that would be great.

Only Twenty Twenty and Twenty Nineteen should be effected as they were the only to get a version bump since the last major.

Reopening for backport.

#4 @SergeyBiryukov
6 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 48029:

Bundled Themes: Bump Twenty Twenty and Twenty Nineteen versions.

This was intended for the WordPress 5.4.2 release, but will now be released with WordPress 5.4.3 instead.

Props ianbelanger, ocean90.
Merges [47800] and [47952] to the 5.4 branch.
Fixes #50359. See #50174.

Note: See TracTickets for help on using tickets.