WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5038 closed defect (bug) (invalid)

Upgraded to 2.3 RC1, now getting database error

Reported by: jeanniebeannie Owned by:
Milestone: Priority: high
Severity: major Version: 2.3
Component: General Keywords: database, categories, error message
Focuses: Cc:

Description

The error below is showing up at the top of the screens on my site after upgrading from 2.2 to 2.3RC1 today. I tried running the upgrade script again but it wouldn't let me, saying the database is already up-to-date. Hmmm.

WordPress database error: [Table 'jeannie_wordpress.wp_categories' doesn't exist]
SELECT * FROM wp_categories ORDER BY cat_name

You can see that the categories do show up (www.jeanniebeannie.com), but the error message.

Please forgive me if this has already been covered, I didn't see anything about it in the forums.

I also get the one below sometimes (like just now when I switched the theme in order to make the previous error msg visible since it was hidden by the other theme).

Warning: Cannot modify header information - headers already sent by (output started at /home/jeannie/public_html/wordpress/wp-includes/wp-db.php:160) in /home/jeannie/public_html/wordpress/wp-includes/pluggable.php on line 383

Thanks,

Jeannie

Change History (2)

comment:1 Nazgul7 years ago

  • Milestone 2.3 deleted
  • Resolution set to invalid
  • Status changed from new to closed

The categories table was removed in 2.3RC1. I assume you've got a plugin running which still tries to use it.

Disable all plugins. Activate them one by one and reload your site after each one. Once you find the culprit. Contact its author and ask him to make it 2.3 compatible.

comment:2 jeanniebeannie7 years ago

Plugins! Of course! *smack forehead*

Thank you for your very fast help.

Note: See TracTickets for help on using tickets.