Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#50381 closed defect (bug) (fixed)

How to activate a theme in wp 5.5 build alpha 47984

Reported by: backups's profile BackuPs Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: major Version: 5.5
Component: Themes Keywords:
Focuses: administration Cc:

Description

Hi

Where is the theme activation button in wordpress 5.5. alpha 47984?

It is gone

https://share.getcloudapp.com/Qwul7eKk

Please advice

Attachments (2)

no-activation-theme-button.jpg (480.5 KB) - added by BackuPs 4 years ago.
screenshot of theme area
active themes.png (500.8 KB) - added by mukesh27 4 years ago.

Download all attachments as: .zip

Change History (12)

@BackuPs
4 years ago

screenshot of theme area

#1 @BackuPs
4 years ago

Please add back the activation in the wordpress appearance theme section and not only in the customizer !

#2 @mukesh27
4 years ago

  • Component changed from General to Themes
  • Focuses administration added

Hi there! Thanks for the ticket.

I face the same issue for trunk version 5.5-alpha-48035.

It shows all the installed theme as an active theme so it is not shown activate button for theme

Last edited 4 years ago by mukesh27 (previous) (diff)

#3 follow-up: @mukesh27
4 years ago

  • Keywords dev-feedback added
  • Severity changed from normal to major

#4 in reply to: ↑ 3 @BackuPs
4 years ago

Replying to mukesh27:

Yes i also noticed that.

But it would be nice if we can activate again a theme from the themes section and not by going to the customizer and then click activate and publish. I don't want this extra click ability nor do i need to be in the customizer for activation.

#5 @mukesh27
4 years ago

Someone from core team will check this issue and fix this ASAP.

#6 @SergeyBiryukov
4 years ago

  • Keywords dev-feedback removed
  • Milestone changed from Awaiting Review to 5.5
  • Owner set to SergeyBiryukov
  • Status changed from new to accepted

Thanks for the report! Introduced in [47924] / #50334.

#7 @SergeyBiryukov
4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 48037:

Themes: Ensure the theme slug is set before checking if the theme is installed or active.

This fixes an issue with every installed theme being marked as active on Themes screen.

The slug is set on Add Themes screen, but not on Themes.

Follow-up to [47924].

Props BackuPs, mukesh27, SergeyBiryukov.
Fixes #50381. See #50334.

#8 @BackuPs
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi

What do you mean by this?

Themes: Ensure the theme slug is set before checking if the theme is installed or active.

Is this going to be fixed or left as it is now. Your answer is not clear to me.

Please advice, Thank you.

Last edited 4 years ago by BackuPs (previous) (diff)

#9 @BackuPs
4 years ago

Never mind i figured it out. Please close

Thank you!

#10 @SergeyBiryukov
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

No worries! Just to clarify, yes, this was a bug which should now be fixed. Thanks again for the report.

Note: See TracTickets for help on using tickets.