WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#50411 closed defect (bug) (fixed)

Ensure the minimum PHP version requirements are met when auto-updating themes

Reported by: desrosj Owned by: desrosj
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Site Health Keywords: has-patch commit
Focuses: Cc:

Description

Follow up of #49653.

When themes are auto-updated, the PHP version requirements are currently not verified.

[47819] landed before the auto-updates UI was merged in [47835]. So checking this requirement was missed.

Attachments (1)

50411.diff (715 bytes) - added by desrosj 6 months ago.

Download all attachments as: .zip

Change History (5)

@desrosj
6 months ago

#1 @audrasjb
6 months ago

  • Keywords commit added

Thanks for spotting this @desrosj !
Patch looks good to me 👍

#2 @desrosj
6 months ago

  • Owner set to desrosj
  • Resolution set to fixed
  • Status changed from new to closed

In 48071:

Site Health: Verify PHP version requirements when auto-updating themes.

Follow up of [47819].
See #49653.
Fixes #50411.

#3 @desrosj
6 months ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.