WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#50459 closed defect (bug) (fixed)

Enable auto-updates link shown fo Must-Use plugins

Reported by: Chouby Owned by: audrasjb
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Security Keywords: has-screenshots has-patch commit
Focuses: Cc:

Description

As Must-Use plugins can't be updated, I suppose that auto-update won't work either. If you confirm, then showing the "Enable auto-updates" link isn't useful (and can be confusing).

Attachments (3)

Capture d’écran 2020-06-23 à 19.31.55.png (66.8 KB) - added by audrasjb 3 months ago.
71b1c7ea069233544433bb489446c345.mp4 (740.9 KB) - added by audrasjb 3 months ago.
50459.diff (1.2 KB) - added by pbiron 3 months ago.

Download all attachments as: .zip

Change History (9)

#1 @audrasjb
3 months ago

  • Owner set to audrasjb
  • Status changed from new to accepted

THanks for spotting this @Chouby
It wasn't shown on the feature plugin, but there is an issue in core, thanks.

#2 @audrasjb
3 months ago

  • Keywords has-screenshots added
  • Severity changed from minor to normal

Issue occurs on both must-use and dropins.

@pbiron
3 months ago

#4 @audrasjb
3 months ago

  • Keywords has-patch commit added

Thanks @pbiron, patch looks good to go 👍

#5 @whyisjake
3 months ago

  • Milestone changed from Awaiting Review to 5.5

#6 @whyisjake
3 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 48149:

Security: Don't display the plugin auto-update options for mu-plugins or dropins.

They can't be updated, so we shouldn't be showing the buttons.

Fixes #50459.

Props Chouby, audrasjb, pbiron.

Note: See TracTickets for help on using tickets.