WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 7 weeks ago

#50525 closed enhancement (fixed)

Use wp.i18n for translatable strings in wp-includes/js/wp-pointer.js

Reported by: ocean90 Owned by: ocean90
Milestone: 5.5 Priority: normal
Severity: normal Version:
Component: I18N Keywords: has-patch has-dev-note
Focuses: javascript Cc:

Description

We should replace the use of wp_localize_script() with the proper JavaScript i18n functions introduced in WordPress 5.0, see #20491 and #45103. This ticket is for wp-includes/js/wp-pointer.js.

Previously: #50235

Change History (3)

#1 @ocean90
3 months ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 48266:

I18N: Use wp.i18n for translatable strings in wp-includes/js/wp-pointer.js.

This removes the usage of wp_localize_script() for passing translations to the script and instead adds the translatable strings in the script directly through the use of wp.i18n and its utilities.

Props swissspidy, ocean90.
See #20491.
Fixes #50525.

#2 @justinahinon
8 weeks ago

  • Keywords needs-dev-note added
Note: See TracTickets for help on using tickets.