WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#50668 closed defect (bug) (invalid)

jquery-migrate.js in latest beta version 5.5 gone?

Reported by: BackuPs Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: External Libraries Keywords:
Focuses: Cc:

Description

Hi

What happened with loading of jquery-migrate.js in wp 5.5? I can still see it in the code but it is not loaded anymore in the latest beta version (5.5-beta2-48482).

Anyway to enable the loading again?
Is it stripped permanently?

Change History (8)

#1 @swissspidy
17 months ago

  • Component changed from General to External Libraries

Hi there!

This is expected, see https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/ for details and information on how you can update your code.

#2 follow-up: @BackuPs
17 months ago

So people have to install a plugin now is that what you are saying? Pfff.
Plugin does not load jquery-migrate.js even if enabled in the settings in wp 5.5. Am i missing something?

Why do i have to set it to version 3.5.1 in order to get jquery-migrate loaded?

Last edited 17 months ago by BackuPs (previous) (diff)

#3 @SergeyBiryukov
17 months ago

From the official jQuery Upgrade Guide:

Version 3.0 of the jQuery Migrate Plugin does not warn about or restore behaviors that were removed in previous major version changes such as jQuery 1.9/2.0. Use the following steps to upgrade from a version of jQuery older than 1.11.0 or 2.1.0 to this new version 3.0:

  1. Upgrade the version of jQuery on the page to the latest 1.x or 2.x version.
  2. Add the uncompressed jQuery Migrate 1.x Plugin to the page.
  3. Optional but recommended, update any plugins in use since later versions are usually the most compatible with recent versions of jQuery.
  4. Test the page and resolve any warnings that appear on the console, using the JQMIGRATE 1.x warning documentation as a guide.
  5. Remove the jQuery Migrate 1.x plugin and ensure that the updated jQuery code on the page continues to work properly with only the latest jQuery 1.x/2.x in use.
  6. Upgrade the version of jQuery on the page to the latest 3.x version and add the uncompressed jQuery Migrate 3.x plugin to the page.
  7. Test the page and resolve any warnings that appear on the console, using the JQMIGRATE 3.x warning documentation as a guide. Report any bugs in third-party plugins to the plugin author.
  8. Remove the jQuery Migrate 3.x plugin and ensure that the page continues to work properly with only the latest jQuery 3.x in use.

Running both Migrate 1.x and Migrate 3.x simultaneously on the same page is not supported.

  • Steps 1 to 3 are what's currently in core.
  • Steps 4 and 5 are what's being done in WordPress 5.5. It's now up to plugin and theme developers to update their code to longer require jQuery Migrate 1.x.
  • Steps 6 and 7 are planned for WordPress 5.6.
  • Steps 8 is planned for WordPress 5.7 or later.
Last edited 17 months ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #core by azaozz. View the logs.


17 months ago

#5 @desrosj
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Going to close this out as it seems to be expected behavior per the documentation post cited above.

#6 in reply to: ↑ 2 @azaozz
17 months ago

Replying to BackuPs:

So people have to install a plugin now is that what you are saying? Pfff.

The plugin is intended for testing/helping to update (super) old jQuery code that may still require jQuery Migrate 1.4.1.

Plugin does not load jquery-migrate.js even if enabled in the settings in wp 5.5.

Just released version 1.0.1 to still be able to do this: https://wordpress.org/plugins/wp-jquery-update-test/.

Why do i have to set it to version 3.5.1 in order to get jquery-migrate loaded?

That's different. For jQuery 3.5.1 the jQuery Migrate version is 3.3.0 (the correct version is added by the plugin).

#7 @BackuPs
17 months ago

@azaozz Thank you for all the explaining. It is clear now.

This ticket was mentioned in Slack in #core by sergey. View the logs.


16 months ago

Note: See TracTickets for help on using tickets.