WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#50697 closed defect (bug) (fixed)

Remove underline in Theme "Enable auto-updates".

Reported by: chetan200891 Owned by: SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: normal Version: 5.5
Component: Themes Keywords: has-screenshots has-patch
Focuses: ui, accessibility, css, administration Cc:

Description

In theme overlay there is underline in "Enable auto-updates". It should be removed to make it consistent with other.

Attachments (5)

Remove-Underline-Before.jpg (228.9 KB) - added by chetan200891 2 months ago.
Before
50697.diff (741 bytes) - added by chetan200891 2 months ago.
Initial patch.
Remove-Underline-After.jpg (229.8 KB) - added by chetan200891 2 months ago.
After applying patch.
50697.1.diff (386 bytes) - added by sabernhardt 2 months ago.
removes underline without !important
50697.underline-author.diff (761 bytes) - added by sabernhardt 2 months ago.
option to underline both author link and button text instead

Download all attachments as: .zip

Change History (10)

@chetan200891
2 months ago

Initial patch.

@chetan200891
2 months ago

After applying patch.

#1 @chetan200891
2 months ago

  • Keywords has-patch added

@sabernhardt
2 months ago

removes underline without !important

@sabernhardt
2 months ago

option to underline both author link and button text instead

#2 follow-up: @sabernhardt
2 months ago

Thanks @chetan200891 !

50697.1.diff changes the selector so the !important is no longer necessary to remove the underline from the button (as intended when it was a link).

However, I highly recommend making it consistent the other way by underlining both the author link and the button text (without underlining the spinner icon). 50697.underline-author.diff clearly distinguishes the blue link from the gray text.

#3 @afercia
2 months ago

  • Focuses accessibility added

The underline shouldn't be removed. Otherwise, this link (actually it's a button that looks like a link) would be distinguishable as an interactive controls only by its color.

Color alone is not sufficient. As in the case of links, the underline is necessary when the context doesn't clarify it's an interactive control.

https://developer.wordpress.org/coding-standards/wordpress-coding-standards/accessibility/#links-underline-or-no-underline

When links can be identified as such by the context, for example because they’re part of a menu, or a set of links clearly identified as user interface controls, they don’t necessarily need to be underlined. In all the other cases, especially for links surrounded by other text (in a line or block of text), links need to be always underlined.

#4 in reply to: ↑ 2 @SergeyBiryukov
2 months ago

  • Milestone changed from Awaiting Review to 5.5

Replying to sabernhardt:

However, I highly recommend making it consistent the other way by underlining both the author link and the button text (without underlining the spinner icon). 50697.underline-author.diff clearly distinguishes the blue link from the gray text.

I agree with that.

#5 @SergeyBiryukov
2 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 48564:

Accessibility: Themes: Consistently use an underline for "Enable auto-updates" link and theme author link in theme overlay.

Props chetan200891, sabernhardt, afercia.
Fixes #50697.

Note: See TracTickets for help on using tickets.