WordPress.org

Make WordPress Core

Opened 4 months ago

Last modified 3 days ago

#50703 reopened defect (bug)

WordPress classic editor accessibility issues for insert/edit links list

Reported by: fornandakishore Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 5.4.2
Component: Editor Keywords:
Focuses: accessibility Cc:

Description

We are facing some keyboard accessibility issues with Insert/edit link list from the editor.

We are not able to access the items from the list using up arrow, down arrow, enter and space keys.

Please find the below image for reference.

http://meedev.westus.cloudapp.azure.com/dev-old/Wp_editor_issue.png

Attachments (3)

Wp_editor_issue.png (32.1 KB) - added by fornandakishore 4 months ago.
50703 classic editor frontend link no search.gif (279.0 KB) - added by afercia 4 months ago.
Selecting a link suggestion (no search term)
50703 classic editor frontend link.gif (423.3 KB) - added by afercia 4 months ago.
Selecting a link suggestion after a search

Download all attachments as: .zip

Change History (11)

#1 @afercia
4 months ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

Thanks for your report @fornandakishore and welcome to Trac.

Based on your screenshot I'm assuming you're using the editor in the front end using wp_editor()? I see the styling of the elements in the modal dialog is likely affected by conflicts with the theme styling. Regardless, this shouldn't directly impact the functionalities of the search and suggestions list.

I did a quick test adding the editor in the front end (theme: Twenty Twenty) and I couldn't reproduce any issue. The styling needs to be adjusted a bit but everything works as expected.

See the attached animated GIF.

I'd tend to think there's probably some JavaScript conflict with some plugins or the theme you're using. Can you confirm that the bug still exists with the default theme (Twenty Twenty) activated and all other plugins deactivated?

@afercia
4 months ago

Selecting a link suggestion (no search term)

@afercia
4 months ago

Selecting a link suggestion after a search

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


4 months ago

This ticket was mentioned in Slack in #accessibility by azhiyadev. View the logs.


3 months ago

#4 @afercia
3 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This ticket was discussed during today's accessibility bug-scrub: since it seems the issue can't be reproduced, the team agreed to close this ticket.

Tickets can always be reopened so please do feel free if you feel something was missed or if you're able to provide more details to reproduce the issue. Also, discussion can continue on closed tickets :)

#5 @fornandakishore
2 months ago

  • Keywords Narrator Focus added
  • Resolution invalid deleted
  • Severity changed from normal to critical
  • Status changed from closed to reopened

Open the editor in New Edge browser latest version and follow the below steps to repro the issue.

  • Click on "Insert Hyperlink" button or Ctrl+k
  • "Paste URL" edit box opens
  • Navigate to options button and invoke
  • Using tab navigate to "Open Link in New Tab" checkbox
  • Press tab key for two times
  • Narrator focus will move to the entire Links list box
  • Now start navigation using up and down arrow keys
  • Verify narrator behavior

#6 @afercia
2 months ago

  • Keywords Narrator Focus removed
  • Milestone set to Awaiting Review
  • Severity changed from critical to normal

@fornandakishore thanks for providing more details. I'm a bit confused though. In your original report you mentioned "some keyboard accessibility issues". Instead, in your last comment you mention problems with Narrator on Windows. Is the latter a new issue or it is the same you originally reported?

I'm not a native English speaker and I do realize language barriers are a thing but I'd kindly ask you to please be a bit more descriptive in your report. A few words to better explain the problem can save a good amount of time spent in testing and debugging :)

#7 @fornandakishore
11 days ago

  • Keywords Narrator Focus added
  • Severity changed from normal to major

@afercia, Sorry for the confusion, expected result is "When a user is navigating through up and down arrow keys, narrator focus should go to each link and announce focused link details" but it is not behaving as expected.

Repro Steps

Open the editor in New Edge browser latest version and follow the below steps to repro the issue.
Click on "Insert Hyperlink" button or Ctrl+k
"Paste URL" edit box opens
Navigate to options button and invoke
Using tab navigate to "Open Link in New Tab" checkbox
Press tab key for two times
Narrator focus will move to the entire Links list box
Now start navigation using up and down arrow keys
Verify narrator behavior

Please find the below links for reference videos
https://meedev.westus.cloudapp.azure.com/dev-old/Narrator%20focus%20is%20not%20moving%20to%20links%20details.webm

https://meedev.westus.cloudapp.azure.com/dev-old/Edge%20Browser%20and%20narrator%20issue.webm

Last edited 11 days ago by fornandakishore (previous) (diff)

#8 @SergeyBiryukov
3 days ago

  • Keywords Narrator Focus removed

Adjusting the keywords per the workflow keywords used here on Trac.

Note: See TracTickets for help on using tickets.