WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#50751 closed defect (bug) (invalid)

Auto-updates, incorrect strings (language) shown after enabling/disabling.

Reported by: kebbet Owned by: audrasjb
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Upgrade/Install Keywords:
Focuses: administration Cc:

Description

I think I found a bug in the plugin screen and the theme screen for the new auto-update feature.

When I click "Aktivera automatiska uppdateringar" (Enable auto-updates) the text changes to English, even though the strings are translated. When "Enabling" (should say Aktiverar...) is done, the text says "Disable auto-updates". When I refresh the page the text says "Inaktivera automatiska uppdateringar" (Disable auto-updates).

Make sure to test with a language that has translated the related strings.

Attachments (1)

50751.gif (559.2 KB) - added by ocean90 3 months ago.

Download all attachments as: .zip

Change History (6)

#1 @audrasjb
3 months ago

  • Owner set to audrasjb
  • Status changed from new to reviewing

@ocean90
3 months ago

#2 @ocean90
3 months ago

  • Keywords reporter-feedback added

I'm assuming you're testing with the sv_SE locale? In this case make sure that /wp-content/languages/sv_SE-2b390f85a3048c5b4255fb45960b6514.json exists. If not, try updating (WordPress and) the translations again on wp-admin/update-core.php. It should work, see 50751.gif.

#3 @kebbet
3 months ago

I am testing with all new files, but as I noted in the slack-channel => ”Seems to work in some environments, and not in other.. I’ll try to dig into it as well.. Might be something on my side...”

#4 @kebbet
3 months ago

  • Resolution set to invalid
  • Status changed from reviewing to closed

Local issue, sorry for the clutter!

#5 @SergeyBiryukov
3 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

No worries, thanks for the follow-up!

Note: See TracTickets for help on using tickets.