WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#50777 closed defect (bug) (invalid)

Multisite not working with latest release

Reported by: glasnik Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4.2
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

With latest WordPress update multi site functionality is broken. I have had a bash script for installing wordpress, which I wrote. The script have feature to enable multisite on install by adding:
define( 'WP_ALLOW_MULTISITE', true );
in wp-config-sample.php, which will be copied to wp-config.php after installation.
It was working fine until latest release.
When I try to enable multisite I go to Tools -> Network Setup and I select subfolder installation and after that I get wp-config.php and apache configuration code. After adding code to wp-config.php and re-logging, network dashboard is missing from the menu. I get logged in just as regular admin, not as network admin. I tried all the options I can, editing database tables and configuration with no success.
Just to be clear, I don't have problem with http server. The problem is that after network setup I get logged in as a regular user/administrator and not as super admin.

Change History (4)

#1 @knutsp
14 months ago

  • Keywords reporter-feedback close added; needs-patch removed
  • Severity changed from blocker to normal

Hello and welcome to Trac!

Are you saying you lately have tried the exact same procedure using WP 5.4.1 - and that is then works?

Have you verified your wp-config.php and see that MULTISITE is defined and true (and not just pre-editing wp-config-sample.php)?

As I recently set up a multisite using 5.4.2 and had no unexpected problems, I don't think it's not generally broken. I have never ever edited wp-config-sample.php so I can't say anything about that.

Have you tried support to get help to find out what's missing, and so we eventually can have a reproducible and actionable issue to look at? At current stage this issue seems like a support question. Please try that and get back with some more information.

Last edited 14 months ago by knutsp (previous) (diff)

#2 @SergeyBiryukov
14 months ago

  • Summary changed from Multisite not working with leatest release to Multisite not working with latest release

#3 @glasnik
14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I have found out where is the issue. The error was mine, however, it might be useful for someone if I post this. The script I have was adding define( 'WP_ALLOW_MULTISITE', true ); to the end of wordpress configuration, below the ABSPATH. Later on, I would manually add the code generated on Network Setup page following the code added by the script and from some reason this was not working. When I add the code above the mentioned it was working fine.
I don't know why it is issue to add the code at the end of file but it was working like this before.

#4 @SergeyBiryukov
14 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted

Thanks for the follow-up!

Just to clarify, putting anything after the /* That's all, stop editing! Happy publishing. */ comment was never recommended. The comment should probably be further clarified to reflect that, see #29688.

Note: See TracTickets for help on using tickets.