WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#50834 closed defect (bug) (fixed)

Correct the check whether .htaccess update is required

Reported by: SergeyBiryukov Owned by: SergeyBiryukov
Milestone: 5.6 Priority: normal
Severity: normal Version:
Component: Permalinks Keywords:
Focuses: administration Cc:

Description

Background: #39547

[27549] / #19268 introduced a check whether .htaccess update is required after saving permalink settings, so that "You should update your .htaccess file now" message is only displayed when necessary.

As part of the changes in [37747] / #35936 and [38066] / #37380, some logic was reshuffled, and the check is now performed before the permalink structure is updated, leading to the message not being displayed as intended, due to outdated values being compared.

The check should be performed after the permalink structure update, not before.

Change History (2)

#1 @SergeyBiryukov
3 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 48710:

Permalinks: Correct the check whether .htaccess update is required when saving permalink settings.

The check should be performed after the permalink structure update, not before.

Fixes #50834.

#2 @SergeyBiryukov
3 months ago

In 48712:

Permalinks: Simplify the logic for displaying "You should update your .htaccess file now" message.

See #39547, #50834.

Note: See TracTickets for help on using tickets.