WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 6 weeks ago

#50851 closed defect (bug) (invalid)

In plugins and themes page select all option isn't working.

Reported by: pooja1210 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: External Libraries Keywords: close reporter-feedback
Focuses: javascript Cc:

Description

Steps to reproduce:

  • Go to the plugins page and click on the checkbox present in the title row
  • This ideally when checked should check all the checkbox from the plugin/themes list, but on clicking it no action is performed

Tested this on two different sites one site with stable version 5.4.2 and another with 5.5-RC2-48740. With the stable WP version that is 5.4.2 and the select, all for plugins/themes are working as expected.

But with WP version 5.5-RC2-48740 select all for plugins/themes is not working as expected.

Attachments (2)

5.4.2.gif (7.9 MB) - added by pooja1210 7 weeks ago.
Visual with stable version and the expected result
5.5-RC2-48740.gif (8.8 MB) - added by pooja1210 7 weeks ago.
Visual with v5.5-RC2-48740 in which the issue exists.

Change History (10)

@pooja1210
7 weeks ago

Visual with stable version and the expected result

@pooja1210
7 weeks ago

Visual with v5.5-RC2-48740 in which the issue exists.

#1 @TimothyBlynJacobs
7 weeks ago

  • Component changed from General to External Libraries
  • Keywords close reporter-feedback added

Thanks for the ticket @pooja1210!

This is most likely an issue caused by a plugin that is using old jQuery functionality that will no longer work in WordPress 5.5 due to jQuery Migrate being removed.

For more info about that see #37110 and https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/

If you open your web browser's developer console, you should be able to see which JavaScript file is causing the error.

#2 @pooja1210
7 weeks ago

@TimothyBlynJacobs

Hi,

I don't see any error in the web browser's developer console.

#3 @TimothyBlynJacobs
7 weeks ago

Could you try deactivating all the plugins @pooja1210?

#4 follow-up: @pooja1210
7 weeks ago

@TimothyBlynJacobs

I tried deactivating all the plugins but couldn't see any errors.

Also, I noticed that select all is working now.

#5 in reply to: ↑ 4 @SergeyBiryukov
7 weeks ago

Replying to pooja1210:

Also, I noticed that select all is working now.

Thanks for the follow-up! By enabling plugins one by one again you should be able to find the one that was breaking it.

#6 @afercia
6 weeks ago

  • Focuses javascript added; accessibility removed

Removing the accessibility label, as this seems related to the removal of jquery-migrate in 5.5.

#7 @desrosj
6 weeks ago

  • Version changed from trunk to 5.5

#8 @TimothyBlynJacobs
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.