Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #50867, comment 8


Ignore:
Timestamp:
08/07/2020 08:54:39 AM (2 years ago)
Author:
talldanwp
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #50867, comment 8

    initial v1  
    55From that, I think `wp_classnames` has definite merit, that part of the code is much easier to read.
    66
    7 `wp_el` is a little harder to read in my opinion, mostly because of the amount of indentation, but I still think it's an improvement over the original concatenated string.
     7`wp_el` is a little difficult to read in my opinion, mostly because of the amount of indentation, but I still think it's an improvement over the original concatenated string.
    88
    99One of the worst parts I find about assembling HTML using current techniques is having to match up opening and closing tags, particularly when there's some conditional logic involved around those tags. It's too easy to make a mistake and end up with invalid HTML.