WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#50869 closed defect (bug) (duplicate)

Vimeo oEmbed now has dnt=1 parameter, and causes numerous videos to be simultaneously playable on a page

Reported by: freshyjon Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Embeds Keywords: has-privacy-review
Focuses: accessibility Cc:

Description (last modified by SergeyBiryukov)

This is a follow-up to #41784.

It seems that Vimeo oEmbed players are now being given a dnt=1 parameter on the Vimeo player’s iframe source URL. This is causing an issue that may have been overlooked.

If there are numerious Vimeo videos embedded on the page, previously (by default), Vimeo would only allow one of those video to play at a time. If a user played one video — then started playing another video — it would then pause the previous video that as playing. Again, this is default Vimeo behavior. However, when the Vimeo URL has the parameter of dnt=1 on the URL, it causes that default behavior to be overridden. Therefore, it allows the user to play multiple videos at once (which is NOT default behavior, and is arguably not very “Accessible friendly”).

I see that it’s likely that [41345] is the culprit. Is there a filter to override this function, with something in the child theme? If not, it seems we’d be forced to either:

  • replace URLs with jQuery
  • embed the Vimeo videos with an iframe code, instead of the oEmbed feature

Ideally, this would be looked in to further, since it now overrides default/expected Vimeo behavior. I argue that it should be removed from Vimeo URLs, or at least have an option to disable it from oEmbeds.

Change History (6)

#1 @carike
3 months ago

  • Focuses privacy removed
  • Keywords has-privacy-review added

:wave:
Hallo.
While oEmbeds have privacy implications, this ticket does not appear to be directly privacy-related (in that it neither seems to "threaten" nor directly improve privacy).
I'm just going to add a "has-privacy-review" tag for our workflow :)
Thank you for marking it for our attention as well. It is appreciated
Please mark as "needs-privacy-review" if the situation changes.

#2 @SergeyBiryukov
3 months ago

  • Description modified (diff)

#4 @afercia
3 months ago

Besides the auto-stop that doesn't work any longer, I see on the linked support forum topic https://wordpress.org/support/topic/wordpress-adding-dnt-parameter-to-embedded-video/ that also the Vimeo statistics aren't displayed correctly any longer.

Is there a specific ticket regarding the statistics issue already? /Cc @johnbillion

#5 @johnbillion
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #46986.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 months ago

Note: See TracTickets for help on using tickets.