WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#5087 closed defect (bug) (fixed)

WYSIWYG Insert/Edit Image button issues

Reported by: bl968 Owned by:
Milestone: 2.5 Priority: high
Severity: critical Version: 2.3
Component: TinyMCE Keywords: reporter-feedback needs-patch WYSIWYG image properties
Focuses: Cc:

Description (last modified by foolswisdom)

Line wraps inserted on html code segments. No linewraps exist on image code in editors.

Internet explorer

Inserting image into post then editing with the insert/edit image wysiwyg button results in duplicated image tag and in both image tags it sets width and height to 1, unless you are setting the width and height to something else then it sets your width and height correctly but still duplicates image code. Example code below.

<img border="0" align="left" width="1" src="http://www.ablogsite/wp-content/uploads/2007/09/test1.jpg" alt="testing" height="1" />
<img border="0" align="left" width="1" src="http://www.ablogsite/wp-content/uploads/2007/09/test1.jpg" alt="testing" height="1" />

In the above example the only action I took on the insert/edit image dialog page was to set the alignment to left.

<a href="http://www.ablogsite.com/wp-content/uploads/2007/09/test.JPG"><img border="0" align="left" width="100" src="http://www.ablogsite.com/wp-content/uploads/2007/09/test.JPG" height="100" /></a>
<img border="0" align="left" width="100" src="http://www.ablogsite.com/wp-content/uploads/2007/09/test.JPG" height="100" />

Above is an example with setting alignment to left and width and height both to 100.

Confirmed in Mozilla Firefox as well

In Mozilla Firefox still duplicates the image code but does not set the image width and height fields.

<img src="http://www.ablogsite/wp-content/uploads/2007/09/test1.jpg" alt="testing" />
<img src="http://www.ablogsite/wp-content/uploads/2007/09/test1.jpg" alt="testing" align="left" />

Problem confirmed with no activated plugins.

Why Critical

I run a community blog site with many authors of varying abilities. For some the only option is the wysiwyg editor. We also use images in articles extensively. Every article has at least one image. A picture is worth a thousand words afterall.

Change History (26)

comment:1 in reply to: ↑ description bl9687 years ago

Also I have tested with all plugins deactivated.

comment:2 bl9687 years ago

  • Component changed from Administration to TinyMCE

comment:3 follow-up: bl9687 years ago

Why is this not showing up on the Ticket status by Component Screen

Ticket status by Component
Administration 1/6
General 1/7
Optimization 0/1
Template 1/2
TinyMCE 0/1 (This ticket is missing)
i18n 1/1

Might want to have whoever maintains trac check it out...

comment:4 in reply to: ↑ 3 ; follow-up: foolswisdom7 years ago

Replying to bl968:

Why is this not showing up on the Ticket status by Component Screen

http://trac.wordpress.org/query?status=new&status=assigned&status=reopened&groupdesc=1&group=component&component=TinyMCE&order=id

It shows up for me. Queries are cached. Did you click Update.

comment:5 in reply to: ↑ 4 ; follow-up: bl9687 years ago

Replying to foolswisdom:

It shows up for me. Queries are cached. Did you click Update.

It shows up on the bugs page but not on the status graph at http://trac.wordpress.org/milestone/2.3.1

comment:6 in reply to: ↑ 5 ; follow-up: foolswisdom7 years ago

Replying to bl968:

It shows up on the bugs page but not on the status graph at http://trac.wordpress.org/milestone/2.3.1

TinyMCE 0/1, this is that 0/1.

comment:7 in reply to: ↑ 6 JeremyVisser7 years ago

Replying to foolswisdom:

TinyMCE 0/1, this is that 0/1.

Pardon?

comment:8 foolswisdom7 years ago

JeremyVisser, bl968 said that it didn't show up on the status graph, but this ticket is that 0/1.

comment:9 follow-up: foolswisdom7 years ago

  • Description modified (diff)

comment:10 in reply to: ↑ 9 bl9687 years ago

Replying to foolswisdom:

Thanks for the cleanup Foolswisdom. I didn't know how to do it.

comment:11 JeremyVisser7 years ago

He's a Trac admin – he's the only one that can do that.

@foolswisdom, I still failed to parse what you said (comment 8), but I'll just ignore that. :)

comment:12 follow-up: bl9687 years ago

This bug still exists in 2.3.1 beta 1. Is anyone working on fixing this issue?

comment:13 in reply to: ↑ 12 westi6 years ago

Replying to bl968:

This bug still exists in 2.3.1 beta 1. Is anyone working on fixing this issue?

I can't reproduce this issue with Firefox
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

comment:14 follow-up: bl9686 years ago

Bug still exists in 2.3.1 RC 1...

comment:15 in reply to: ↑ 14 westi6 years ago

  • Keywords reporter-feedback needs-patch added

Replying to bl968:

Bug still exists in 2.3.1 RC 1...

Thank you for this update.

Unfortunately I can't reproduce this issue.

Are you able to debug the issue or give more detailed information on how to reproduce?

comment:16 bl9686 years ago

Server: Apache/2.0.61 (Unix) PHP/5.2.2

Steps:

  1. Go to write post screen[br]
  2. upload and/or insert image[br]
<img src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" />

[br]

  1. Edit image with the insert/edit image button (alt-m)[br]
  2. Change image alignment to left.[br]
<img border="0" align="left" width="1" src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" height="1" /><img border="0" align="left" width="1" src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" height="1" />

This is the image code notice width and height are set to 1 even though we did not change the width or height on the image. Also the image tag has been duplicated.[br]

Anything else you would like to know I will be happy to provide. If you have anything you wish for me to try just let me know.

comment:17 bl9686 years ago

Server: Apache/2.0.61 (Unix) PHP/5.2.2

Steps:

  1. Go to write post screen
  1. upload and/or insert image[br]

<img src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" />

  1. Edit image with the insert/edit image button (alt-m)
  1. Change image alignment to left.

<img border="0" align="left" width="1" src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" height="1" /><img border="0" align="left" width="1" src="http://www.clarksvilleonline.com/wp-content/uploads/2007/10/co-gateway.jpg" height="1" />

This is the image code notice width and height are set to 1 even though we did not change the width or height on the image. Also the image tag has been duplicated.[br]

Anything else you would like to know I will be happy to provide. If you have anything you wish for me to try just let me know.

(I really hate the formatting here)

comment:18 bl9686 years ago

You can reach me by phone at 931-920-0043 or via im at ICQ: 560860, msn messenger at blarson@…, or aim at BillLarson968

comment:19 neoen6 years ago

I confirm this problem in IE7. I twould be very helpfull to resolve this problem with inserting images...

comment:20 westi6 years ago

  • Milestone changed from 2.3.1 to 2.3.2

2.3.1 has been released moving to 2.3.2

comment:21 Spikecity6 years ago

Yep, confirmed not working in IE7 with 2.3.1.
As long as you only upload and do not edit the image paramaters in TinyMCE the image is shown, after setting alignment (not touching size) the image "disappears" in de online wysiwyg editor.

Opening up the code reveals width and height inserted as = "1" and the complete image url including height en width again set to 1 duplicated behind the original achored image url.

comment:22 mzeecedric6 years ago

Is there any patch or hack to this yet?

comment:23 betacire6 years ago

I have the same problem with mu-wordpress 1.3.
I installed two instances of mu-wordpress on the same hosting. No problem with 1.2.5a, problem occurs only with 1.3.

Have you an idea ? Where to search to correct this problem ?

Thanks.

comment:24 kathleena6 years ago

I'm having the same problem in IE7 with 2.3.1

I'm not sure how to interpret this system. Any word on a fix would be appreciated. Does the Milestone 2.3.2 mean that the fix is scheduled for the next release?

Thanks!

comment:25 lloydbudd6 years ago

  • Milestone changed from 2.3.2 to 2.5

comment:26 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this on WP 2.5 with FF2. It looks like TinyMCE 3.0 fixes this. Closing as fixed in 2.5.

Note: See TracTickets for help on using tickets.