WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#5088 closed defect (bug) (fixed)

Visual Editor Disabled, Editing a Page With HTML Encoded Entities &lt;span&gt; changes them into <> changing the content

Reported by: foolswisdom Owned by:
Milestone: 2.3.1 Priority: highest omg bbq
Severity: critical Version: 2.3
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description (last modified by foolswisdom)

Editing a Page With HTML Encoded Entities &lt;span&gt; changes them into <> changing the content

ENV: WP trunk (2.3+r6172)
User Profile > Uncheck (DISABLE) Use the visual editor when writing

Repro: Always
Steps:

  1. Create a page with Page Content of

&lt;span&gt;

  1. Publish the page
  2. Edit the page again

ACTUALLY RESULT:
The Page Content is now
<span>

EXPECTED RESULT:
The Page Content should still be
&lt;span&gt;

Change History (14)

#1 @foolswisdom
14 years ago

  • Description modified (diff)

#2 @foolswisdom
14 years ago

  • Keywords noTinyMCE added
  • Summary changed from Editing a Page With HTML Encoded Entities &lt;span&gt; changes them into <> changing the content to Visual Editor Disabled, Editing a Page With HTML Encoded Entities &lt;span&gt; changes them into <> changing the content

#3 @bglickstein
14 years ago

As I described in my original report, issue #5084, this also happens in the other direction: non-encoded HTML entities become encoded.

#4 @bglickstein
14 years ago

  • Cc bobg@… added

#5 @foolswisdom
14 years ago

bglickstein, please try to isolate the "other direction" issue you are encountering and write a bug report with repro steps. Posts not pages? Can you only repro it with posts made from XML-RPC? What blog client are you using?

#6 @Viper007Bond
14 years ago

I'm unable to reproduce this using latest SVN. I did exactly as the original ticket described and I got the exact code I originally entered after editing the post.

#7 @Viper007Bond
14 years ago

Er, I misread. It works fine for posts, it is indeed broken for pages.

#8 @Viper007Bond
14 years ago

  • Component changed from General to Administration
  • Keywords needs-patch added; noTinyMCE removed
  • Priority changed from high to highest omg bbq

#9 @johnbillion
14 years ago

bglickstein, can you verify this bug still exists with all your plugins disabled?

#10 @cosmix
14 years ago

This seems to be a core bug. It is always reproducible without any active plugins on 2.3. I managed to get this working by adding the format_to_edit() and apply_filters() lines taken from the same function on 2.2.3 to the get_post_to_edit() found in wp-admin/includes/post.php at line 162 on WP2.3. Since I am not familiar with the design of WP and the changes that took place between 2.2.3 and 2.3 this might be a very wrong way of fixing this; this is why I am not attaching a patch here. In any case, I hope it helps someone to find a better solution.

#11 @cosmix
14 years ago

Note that the suggested 'fix' above breaks posts.

#12 @raptorNL
14 years ago

Problem seems to be fixed in the latest development revision (6226).

#13 @ryan
14 years ago

I think [6184] fixed this. Should be fixed in trunk and the 2.3 branch.

#14 @ryan
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Resolving as fixed. If you can reproduce this using the latest from the 2.3 branch, please re-open.

Note: See TracTickets for help on using tickets.