WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#50905 closed defect (bug) (invalid)

Bug of both classic editor plugin and Featured image after update to 5.5

Reported by: christelleneant Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Editor Keywords:
Focuses: Cc:

Description

Good evening,
Your last update is a pure disaster. I used the classic editor plugin because your block editor is a full mess, and now it does not work anymore since your update. I can only edit in HTML mode and not in visual !
So I tried to publish my last article in your block editor, but impossible to add a featured image, I have a white page with "Featured image" title showing on the top and that is all.

Change History (9)

#1 @SergeyBiryukov
5 weeks ago

  • Milestone changed from Awaiting Review to 5.5.1

This ticket was mentioned in Slack in #core by brettkrueger. View the logs.


5 weeks ago

#3 @xjamasterx
5 weeks ago

I'm also experiencing major issues since the update. I'm unable to view html in posts whether the classic editor is turned on or off.

Lots of people are having this issue: https://wordpress.org/support/topic/5-5-classic-editor-text-view-add-media-not-working/

Last edited 5 weeks ago by xjamasterx (previous) (diff)

#4 @iCaleb
5 weeks ago

It’s quite likely the conflicts exist with other plugins that are extending the classic editor.

Installing this has a high chance of returning things to functional, so I would recommend giving it a try: https://wordpress.org/plugins/enable-jquery-migrate-helper/

More info: https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/

#5 @SergeyBiryukov
5 weeks ago

  • Keywords close reporter-feedback added

Hi there, welcome to Trac! Thanks for the report. Just noting that I could not reproduce the issue on a clean install.

I'm sorry to hear you are having issues with your website since the latest update, but this topic is best discussed on the support forums or directly with the developer of your theme or website.

Before heading there to create a post though, I recommend reading through the following list of potential issues with 5.5: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/

The most likely issue is that a plugin on your site is running old JavaScript code. As suggested above, could you try installing and activating this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

This will confirm that there is JavaScript on your site that needs to be updated to follow more modern jQuery practices. You can leave the plugin active for the time being, but the breaking code will need to be updated before the next step of the Upgrading jQuery in Core roadmap.

If this does not fix the issue, feel free to create a support topic.

#6 @christelleneant
5 weeks ago

I will not have time before Sunday to do tests. Other people said it seems it is Yoast SEO plugin which is putting the mess. Indeed I have it on my website.

#7 @christelleneant
5 weeks ago

Installation of Enable jQuery Migrate Helper solved the problem, I could upadte to WP 5.5 and everything works now.

#8 @Otto42
4 weeks ago

  • Milestone 5.5.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug. WordPress 5.5 intentionally removed the jQuery Migrate library, and you should upgrade your plugins and themes and any other addons to software that does not require it.

Future WordPress updates will be updating the jQuery library as well, so you should inform plugin and theme authors to test with newer versions of the jQuery library. There is a plugin to help them do that as well, and full details about this can be found here:
https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/

#9 @SergeyBiryukov
4 weeks ago

  • Keywords close reporter-feedback removed
  • Severity changed from critical to normal
Note: See TracTickets for help on using tickets.