WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#50950 closed defect (bug) (duplicate)

Posts show wrong time when user is in a different time zone than the site's

Reported by: rfischmann Owned by:
Milestone: Priority: normal
Severity: major Version: 5.5
Component: Date/Time Keywords:
Focuses: Cc:

Description

I'm in GMT+1, my site is configured in GMT-3 time zone — so I'm 4 hours ahead.

WordPress' editor in version 5.5 is showing the post's time as if it was published 4 hours before, example: https://d.pr/i/wAw9iV

If I click the post's date/time, it shows the correct time: https://d.pr/i/L4TlQd

Just so it's completely clear: that post was published at 11:41AM GMT-3, and that was 3:41PM GMT+1 for me.

So the editor is considering that my time zone should be the post's, and it's then subtracting 4 hours because of the time zone difference. Very weird behavior.

Change History (3)

#1 @rfischmann
8 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #50949.

Sorry, I don't know why the ticket was opened twice.

#2 @johnbillion
8 months ago

  • Milestone Awaiting Review deleted

No problem, sometimes the gremlins come out.

#3 @SergeyBiryukov
8 months ago

  • Component changed from General to Date/Time
Note: See TracTickets for help on using tickets.