WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#50960 closed defect (bug) (invalid)

v5.5 messed entire site

Reported by: saarikko Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.5
Component: Administration Keywords:
Focuses: ui, javascript, css, rtl, administration, template, multisite, performance, coding-standards Cc:

Description (last modified by jorbin)

My WordPress decided to update itself without my knowledge (no kind of notification was sent from the server) and next time I logged in (today) I wasn't able to hit any of the plug-in's settings tabs, couldn't check the theme for updates (Envato) and my pages went blank from text, editing the pages didn't have Elementor enabled anymore and my images have become "free of use" on the web after the right click prevention plug-in stopped from working due to this update of yours!

Thank you! Just some hard 2-3 months editing to get my website up and running again after 2 years of silence and this happens. Now I have to re-install everything from scratch.
I want v5.3 back (this one worked like a charm) without delays on page loads and the theme and plug-ins didn't crash with it!

Change History (9)

#1 @jorbin
14 months ago

  • Description modified (diff)
  • Summary changed from v5.5 fucked entire site to v5.5 messed entire site

This ticket was mentioned in Slack in #core by helen. View the logs.


14 months ago

#3 @Ipstenu
14 months ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

I'm very sorry you;'re having this issue.

WordPress does not automatically upgrade itself for major releases (which 5.5 was). It's possible your webhost did this for you, and if you do not have any plugins that may have auto-updated, I recommend you reach out to your host directly for help.

You can also try installing https://wordpress.org/plugins/enable-jquery-migrate-helper/ which may help.

Otherwise, you should review https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/ and post in the forums if you need more help.

While I'm marking this as 'invalid' it is only because the ticket is not an issue with WordPress core but with your specific configuration. In no way does it mean your problems are not real, just that this, sadly, is not the correct place to report them.

#4 @jorbin
14 months ago

  • Keywords close removed

Hi saarikko, welcome to trac. We do try to encourage respectful discourse here, so I have modified your post help with that.

This Trac is used for discussing bugs in the core software. It sounds like you have some problems with your plugins and/or themes. I would encourage you to reach out to the support forum or to your theme/plugin authors directly.

If you had not enabled auto-updates, you are best off contacting your host.

All that said, this is most likely an issue caused by a plugin that is using old jQuery functionality that will no longer work in WordPress 5.5 due to jQuery Migrate being removed.
A summary about that can be found in the "jQuery Migrate is Disabled by Default" section of the 5.5 upgrade guide: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/#post-13238244

For more info about that see #37110 and https://make.wordpress.org/core/2020/06/29/updating-jquery-version-shipped-with-wordpress/

If you open your web browser's developer console, you should be able to see which JavaScript file is causing the error: https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/

You can also try deactivating all plugins and reverting to the default theme then reactivating them one by one to pinpoint the issue.

#5 @saarikko
14 months ago

Funny how you edit my text and deny my freedom of speech by doing so.

Don't blame my host. My host doesn't go and update anything because they don't manage the server. It's a dedicated server that I manage myself and I know what I'm doing with it. The auto-update is disabled and last time I checked my version was 5.3 and now the first I saw when I logged in was "What's new with 5.5" splasher.

Tried to update the plug-ins but nothing happened. The site was a mess.
All my forms, text etc were gone.
Checking the debug tab and one of the lines has a roller rolling in infinite and the drop down tabs won't work when clicking on them.

So no, the problem is not on my side. It's your update!

#6 @saarikko
14 months ago

I downgraded my version back to 5.3 and now everything seems to work again.

#7 @johnbillion
14 months ago

  • Milestone Awaiting Review deleted

This ticket was mentioned in Slack in #core-coding-standards by peterwilsoncc. View the logs.


13 months ago

This ticket was mentioned in Slack in #core-multisite by peterwilsoncc. View the logs.


13 months ago

Note: See TracTickets for help on using tickets.