WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 4 months ago

#50985 closed defect (bug) (invalid)

Classic Editor Problem With WordPress 5.5

Reported by: luk741239586 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Editor Keywords:
Focuses: Cc:

Description

Hello, We and others who have buy theme on envato market has problem after update of worpdress 5.5, for example of us, we have jnews theme and after update of 5.5 classic editor run with bugs and erros, please see whats wrong becaouse too many company used jnews theme and classic editor plugin..

Thank you...

Change History (2)

#1 @desrosj
9 months ago

  • Component changed from Plugins to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed

Hi there @luk741239586,

Welcome to Trac!

Unfortunately, this is not the right area for a support request like this. This type of post is more appropriate for the WordPress.org support forums. Additionally, no support is provided for 3rd party plugins and themes such as those purchased through Envato. I recommend you create a support request directly with them.

Before heading there to create a post though, I recommend reading through the following list of potential issues with 5.5: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/

The most likely issue is that a plugin on your site is running old JavaScript code. Could you try installing and activating this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

This will confirm that there is JavaScript on your site that needs to be updated to follow more modern jQuery practices. You can leave the plugin active for the time being, but the breaking code will need to be updated before the next step of the Upgrading jQuery in Core roadmap.

If this does not fix the issue, feel free to create a support topic.

#2 @oxpal
4 months ago

Hi @desrosj, I am no expert, but I don't see how it could be an issue with themes or plugins. Is it not more likely that the Classic Editor is using outdated JavaScript?

On my blog I disabled all plugins one by one, and it didn't fix the issue. Only the migration plugin does. I have turned off my custom theme, and switched to twenty-twenty-one, cleared the cashes ... and the issue persisted. Which makes sense, as the issue is on the admin panel, where for all I know my theme doesn't change anything.

Seeing that the issue is 5 month old (ouch): I don't have it that long. It only popped up after 5.6. This is super frustrating - as I give the Gutenberg editor tries every now and then, and it still feels completely unusable.
I really wish this issue could be solved. I see it mentioned by many users in tons of WordPress support forums threads.

Note: See TracTickets for help on using tickets.