WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 4 weeks ago

#50993 closed defect (bug) (duplicate)

Media Library not loading images

Reported by: adambrown82 Owned by:
Milestone: Priority: normal
Severity: major Version: 5.5
Component: Script Loader Keywords:
Focuses: Cc:

Description

There is a fault with WordPress Version 5.5.

As soon as I update to the latest version of WordPress, I no longer see my images in the media section. So I have restored back to the older version.

This bug needs addressing! Thank you

Attachments (3)

Screen Shot 2020-08-13 at 10.11.53 pm.png (127.4 KB) - added by adambrown82 5 weeks ago.
image library is missing in update 5.5
Screen Shot 2020-08-13 at 10.28.35 pm.png (3.6 MB) - added by adambrown82 5 weeks ago.
image library is missing in update 5.5.. this is a restored version of wordpress
Issue 50993 - Twenty Twenty theme Gutenberg 8.7.1 and Yoast SEO 14.7.jpg (191.6 KB) - added by bobbingwide 5 weeks ago.
screenshot of the console log from Media Library with Twenty Twenty theme, Gutenberg 8.7.1 and WordPress SEO 14.7

Change History (11)

@adambrown82
5 weeks ago

image library is missing in update 5.5

@adambrown82
5 weeks ago

image library is missing in update 5.5.. this is a restored version of wordpress

#1 @hometowntrailers
5 weeks ago

I have this identical issue on WP 5.5 with YOAST 14.7 and GUTENBERG 8.7.1 activated. If I disable either of those plugins, the issue disappears.

Last edited 5 weeks ago by hometowntrailers (previous) (diff)

#2 @SergeyBiryukov
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Summary changed from Media issues to Media Library not loading images

Hi there, welcome to Trac! Thanks for the report.

I'm sorry to hear you are having issues with your website since the latest update, but this topic is best discussed on the support forums or directly with the developer of your theme or website.

Before heading there to create a post though, I recommend reading through the following list of potential issues with 5.5: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/

The most likely issue is that a plugin on your site is running old JavaScript code. Could you try installing and activating this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

This will confirm that there is JavaScript on your site that needs to be updated to follow more modern jQuery practices. You can leave the plugin active for the time being, but the breaking code will need to be updated before the next step of the Upgrading jQuery in Core roadmap.

If this does not fix the issue, feel free to create a support topic.

This ticket was mentioned in Slack in #core-editor by bobbingwide. View the logs.


5 weeks ago

#4 @bobbingwide
5 weeks ago

  • Component changed from Media to Script Loader
  • Resolution invalid deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

Hi, I think this issue should be re-opened. While I was unable to reproduce the problem in a local development environment, I got the same results as @adambrown82 using the same plugins as @hometowntrailers

Applying the fix for #50999 fixed the problem.

@bobbingwide
5 weeks ago

screenshot of the console log from Media Library with Twenty Twenty theme, Gutenberg 8.7.1 and WordPress SEO 14.7

This ticket was mentioned in Slack in #core-editor by bobbingwide. View the logs.


5 weeks ago

#6 @bobbingwide
5 weeks ago

To recreate the problem you have to be working in Grid view.
Problem occurs with Twenty Twenty, Twenty Nineteen etc.

Reproduce

  • Install and activate Gutenberg 8.7.1 and WordPress SEO 14.7
  • Visit Media library
  • If problem has not yet occurred change the URL to

https://example.com/wp-admin/upload.php?mode=grid

Workaround
Change the URL in the address bar to https://example.com/wp-admin/upload.php?mode=list

Last edited 5 weeks ago by bobbingwide (previous) (diff)

#7 @desrosj
5 weeks ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Thanks for digging into this @bobbingwide!

Since this is fixed by the patch in #50999 and that is now milestoned for 5.5.1, I am going to close this one out as a duplicate.

#8 @bobbingwide
4 weeks ago

I retested with Gutenberg 8.8.0. The problem no longer occurs. The fix for #50999 isn't necessary.

Note: See TracTickets for help on using tickets.