WordPress.org

Make WordPress Core

Changes between Version 2 and Version 3 of Ticket #51043, comment 9


Ignore:
Timestamp:
08/17/2020 08:39:10 PM (14 months ago)
Author:
SergeyBiryukov
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #51043, comment 9

    v2 v3  
    33I also don't think we need to look at the PHP usage for *all* WP versions here, as those on WP <5.2 are unlikely to update WP or PHP. I believe we only looked at WP 4.9 to 5.1 when bumping the requirement in WP 5.2, and I think we should do the same here.
    44
    5 If we look at the recent WP versions (5.2 to 5.5), 78.52% of those are already on PHP 7.1 or later (as opposed to 66% for all WP versions). That means only 21.48% of those are on PHP 5.6 or 7.0. That is still high, but could be brought down to a more acceptable number by the end of year with some brainstorming and coordinated efforts.
     5If we look at the recent WP versions (5.2 to 5.5), 78.52% of those are already on PHP 7.1 or later (as opposed to 66% for all WP versions). That means only 21.48% of those are on PHP 5.6 or 7.0. That is still high, but could be brought down to a more acceptable number by the end of year with some brainstorming and coordinated efforts between Site Health and Hosting teams. Just closing the ticket doesn't seem productive for anyone :)