WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#51065 closed defect (bug) (invalid)

Upgrade to WP 5.5 breaks hamburger menu on mobile

Reported by: chabekah Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Menus Keywords:
Focuses: ui Cc:

Description

I updated to WP 5.5 from 5.4.2 yesterday and noticed a couple of odd things that I suspect are related:

  1. On a desktop, there is single upward motion animation over the header menu at the top of the page on page load that is new.
  2. On a small screen, the hamburger menu briefly appears on the top right corner of the page, and then shrinks very quickly. It cannot be clicked - which prevents users on small screens from accessing the navigation and menu on the site.

As I upgraded a number of plugins at the same time as I did the 5.5 upgrade, I wasn't sure whether it was a plugin upgrade that had caused the issue. Rolling back all the plugins but remaining on WP 5.5 did not solve the issue. But then rolling back to 5.4.2 resolved it. Upgrading back again to 5.5 resulted in the same broken behaviour.

The website is currently running WP 5.5 and can be found at https://info.qurangateway.org/. The site uses a custom theme based on twenty_sixteen. It is likely that my theme is incompatible with WP 5.5 - but I would like to know what the problem is so that I can fix it, otherwise I will have to rollback to 5.4.2 and stay there which is not ideal.

Change History (4)

#1 @fierevere
11 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Please use support forums for your issue:
https://wordpress.org/support/forums/
or you can try TwentySixteen theme support forum: https://wordpress.org/support/theme/twentysixteen/

As your first step for fixing problem you can install this plugin
https://wordpress.org/plugins/enable-jquery-migrate-helper/
to restore jquery-migrate.

Then look if you have any issues in browser console (browser developer tools)

I'm closing this ticket. Please use support forums.

#2 @SergeyBiryukov
11 months ago

  • Keywords responsive twenty_sixteen navigation mobile removed
  • Milestone Awaiting Review deleted

#3 @chabekah
11 months ago

It was a jquery-migrate issue. Once I replaced the code in our child theme that was using the deprecated jQuery API (.toggle and .load) then functionality was restored. Using the 'enable-jquery-migrate-helper' helped to diagnose this. Thanks folks!

#4 @SergeyBiryukov
11 months ago

Thanks for the follow-up, and welcome to WordPress Trac :)

Note: See TracTickets for help on using tickets.