WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#51111 closed defect (bug) (duplicate)

Privacy export test errors on Windows

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Privacy Keywords:
Focuses: Cc:

Description

Background: #39975, #40856, #50664.

When running the test suite on Windows, occasionally I get some errors:

There were 4 errors:

1) Tests_Privacy_WpPrivacyDeleteOldExportFiles::test_expired_files_should_be_deleted
unlink(S:\home\wordpress.test\develop/build/wp-content/uploads/wp-personal-data-exports/test_contents/): Is a directory

S:\home\wordpress.test\develop\build\wp-includes\functions.php:7324
S:\home\wordpress.test\develop\tests\phpunit\tests\privacy\wpPrivacyDeleteOldExportFiles.php:120

2) Tests_Privacy_WpPrivacyDeleteOldExportFiles::test_unexpired_files_should_not_be_deleted
unlink(S:\home\wordpress.test\develop/build/wp-content/uploads/wp-personal-data-exports/test_contents/): Is a directory

S:\home\wordpress.test\develop\build\wp-includes\functions.php:7324
S:\home\wordpress.test\develop\tests\phpunit\tests\privacy\wpPrivacyDeleteOldExportFiles.php:131

3) Tests_Privacy_WpPrivacyDeleteOldExportFiles::test_index_file_should_never_be_deleted
unlink(S:\home\wordpress.test\develop/build/wp-content/uploads/wp-personal-data-exports/test_contents/): Is a directory

S:\home\wordpress.test\develop\build\wp-includes\functions.php:7324
S:\home\wordpress.test\develop\tests\phpunit\tests\privacy\wpPrivacyDeleteOldExportFiles.php:142

4) Tests_Privacy_WpPrivacyDeleteOldExportFiles::test_filtered_expiration_time
unlink(S:\home\wordpress.test\develop/build/wp-content/uploads/wp-personal-data-exports/test_contents/): Is a directory

S:\home\wordpress.test\develop\build\wp-includes\functions.php:7324
S:\home\wordpress.test\develop\tests\phpunit\tests\privacy\wpPrivacyDeleteOldExportFiles.php:155

Only seems to happen if the wp-content/uploads/wp-personal-data-exports/test_contents/ directory is older than 6 days, as wp_privacy_delete_old_export_files() tries to delete it and fails.

Change History (2)

#1 @SergeyBiryukov
9 months ago

  • Component changed from Build/Test Tools to Privacy

#2 @garrett-eclipse
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #48265.

Note: See TracTickets for help on using tickets.