WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#51150 closed defect (bug) (duplicate)

WP5.5 Scheduled Post - Timezone issue

Reported by: papayoulele Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Date/Time Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Following WP5.5 update, we observed a timezone issue with the WordPress "Schedule a Post" feature.

According to https://make.wordpress.org/support/user-manual/content/posts/schedule-a-post/ , the input box to select the time should match the timezone defined in the WordPress General Settings.

Since the update, we observed that the input box timezone matches the browser/OS timezone instead of the wordpress settings' timezone.

How to reproduce

  • Set the client OS (e.g. windows) timezone to Canada (UTC-06)
  • In WordPress settings > general : set the timezone to Brussels (UTC+01)
  • Make sure the server timezone is also Brussels
  • Try to schedule a post by typing the current client OS time in the input box (e.g. 11h00)
  • The UI displays that the post is scheduled 7h later : 19h00

A linked issue is that the "scheduling" button is transformed into the "publish" button when inputting time anterior to the server time for the current date. The consequence is that such posts are instantly published instead of scheduled. Such posts can thus no longer be scheduled at the wished time.


Change History (3)

#1 follow-up: @Rarst
3 months ago

  • Description modified (diff)

Sounds like related or duplicate of #50949

You could try installing the latest Gutenberg as plugin and see if that helps, reportedly it doesn't have the issue.

#2 in reply to: ↑ 1 @papayoulele
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to Rarst:

Sounds like related or duplicate of #50949

You could try installing the latest Gutenberg as plugin and see if that helps, reportedly it doesn't have the issue.

Sorry that I missed this ticket.
It seems indeed to be related or duplicate.
I think the only "fresh" element in this ticket is the behavior of the publish/schedule button when scheduling on the same day.

This issue has also been resolved by installing the Gutenberg plugin.

#3 @SergeyBiryukov
3 months ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.