Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51195 closed defect (bug) (duplicate)

.is-style-squared css error

Reported by: ryentzer's profile ryentzer Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: css Cc:

Description

When working through my own theme skeleton with the themeunittestdata.wordpress.xml, I came across the buttons section. The css for the square button is incorrectly applied. If you compare the selectors of is-style-squared to is-style-outline, you should see the problem.

Both is-style-squared and is-style-outline:

.wp-block-button.is-style-squared,
.wp-block-button__link.wp-block-button.is-style-squared {
  border-radius: 0;
}
.wp-block-button.is-style-outline .wp-block-button__link,
.wp-block-button__link.is-style-outline {
  color: #32373c;
  background-color: transparent;
  border: 2px solid;
}

Corrected is-style-squared:

.wp-block-button.is-style-squared .wp-block-button__link,
.wp-block-button__link.is-style-squared {
  border-radius: 0;
}

Change History (2)

#1 @desrosj
3 years ago

  • Component changed from General to Build/Test Tools
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.5 deleted

Duplicate of #51194.

This ticket was created twice. Closing as duplicate.

#2 @ryentzer
3 years ago

My apologies. The browser said there was an error so I re-submitted. Thanks.

Note: See TracTickets for help on using tickets.