Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#51203 closed enhancement (wontfix)

"Uncategorized" isn't translated into Spanish in Default Post Category of Writing Settings

Reported by: zurizuniga Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

Looks like the word "uncategorized" isn't translated into Spanish when changing the language into Spanish (Mexico).

How to replicate:
Lang: Spanish (Mexico)
Ajustes -> Escritura -> Categoría predeterminada para las entradas -> Uncategorized

Maybe a good translation would be: "no clasificada" or "sin clasificacion"

Change History (9)

#1 @justinahinon
17 months ago

  • Component changed from General to I18N

#2 @justinahinon
17 months ago

Welcome to @zurizuniga. Thank you for opening this.

I can confirm I can replicate this on Spanish (Mexico), but also on other locales such as French. Working on a fix.

Last edited 17 months ago by justinahinon (previous) (diff)

#3 @justinahinon
17 months ago

Ok, looks like the "Uncategorized" is not translated in other places in the admin.

#4 follow-up: @ocean90
17 months ago

  • Keywords close added

The default category is added during the initial installation by wp_install_defaults(). So the translation depends on the locale used during the installation.

#5 in reply to: ↑ 4 @knutsp
17 months ago

Replying to ocean90:

The default category is added during the initial installation by wp_install_defaults(). So the translation depends on the locale used during the installation.

I can confirm this to be correct, at least for nb_NO. If I download and manually install the localized package, then the term is translated. If I use an automated service like Softaculous (cPanel), even if I select correct language to be used, the localized package is not used and the term appears in en_US.

#6 @justinahinon
17 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Based on the previous comments, and some discussions I had with the FR locale translation team, I'm closing this as wontfix .

Anyone, feel free to reopen it if needed.

#7 @audrasjb
17 months ago

  • Keywords needs-patch close removed
  • Milestone Awaiting Review deleted
  • Version 5.5 deleted

#9 @zurizuniga
17 months ago

Wouldn't it be helpful to add into documentation that people should edit "Uncategorized" when they see it and that determining the language upon installation will determine the sample data?

#10 @carike
16 months ago

#51357 was marked as a duplicate.

Note: See TracTickets for help on using tickets.