Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#51217 closed defect (bug) (wontfix)

Media library images in sqaure.

Reported by: abhilash10's profile abhilash10 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Hello,
I have one website in WP when I went to the media library all images showing in a square, not in the original aspect ratio.

Attachments (2)

screenshot-admin.womenscriczone.com-2020.09.02-17_41_05.png (957.9 KB) - added by abhilash10 4 years ago.
screenshot-15.206.100.27-2020.09.02-17_43_41.png (545.9 KB) - added by abhilash10 4 years ago.
Before look like this

Download all attachments as: .zip

Change History (5)

#1 @desrosj
4 years ago

  • Component changed from General to Media
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version 5.4.2 deleted

Hi @abhilash10,

Thanks for creating this ticket, and welcome to Trac!

The screen shot of what you are seeing currently is the intended behavior. When an image is uploaded, several smaller subsizes are created for display in different locations. The image used in the media library is the thumbnail image, which is a square 150x150 image by default that is cropped.

Based on the before image, I am thinking that the images showing uncropped with the letterbox-like display are very large and your server was unable to create the thumbnail subsize for those images. You can see that 5 of the images there do take up the entire square, so those most likely generated the subsizes successfully.

Because this is intended behavior, I am going to close this out. If you need further support, the WordPress.org support forums is a more appropriate place for help with something like this.

#2 @abhilash10
4 years ago

Before image the same as now image. I have imported all images from my old website.
I have added the same as the old website. Can you suggest me anything related to this?

#3 @SergeyBiryukov
4 years ago

#51244 was marked as a duplicate.

Note: See TracTickets for help on using tickets.