WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#5122 closed defect (bug) (duplicate)

Database Error when posting with 2.3

Reported by: danesmith Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: General Keywords: bug, posting, saving
Focuses: Cc:

Description

Hello,

I upgraded my WordPress Blog from 2.2.3 the other day to 2.3, and whenever I post or attempt to save, I get a database error which i've attached below. I performed the upgrade exactly as directed, I even reuploaded the files to 2.3. The post still publishes, however....

WordPress database error: [Table 'exoendo.wp_post2cat' doesn't exist]
SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

WordPress database error: [Table 'exoendo.wp_post2cat' doesn't exist]
SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

Warning: Cannot modify header information - headers already sent by (output started at /home/exoendo/exoendo.net/public_html/wp-includes/wp-db.php:160) in /home/exoendo/exoendo.net/public_html/wp-includes/pluggable.php on line 390

Change History (1)

comment:1 @Nazgul8 years ago

  • Milestone 2.5 deleted
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Duplicate of #5044, #5014 and #5013.

The post2cat table is no longer part of Wordpress with the 2.3 release, so I assume you're running a plugin which isn't compatible with 2.3.

Disable all plugins. Activate them ony by one, testing your blog in between. When you've found the culprit, update it to a 2.3 compatible version, or if that's not available ask the author of that plugin to create one.

The most commen "culprit" is the Google Sitemaps plugin. (Which has a new 2.3 compatible version available)

Note: See TracTickets for help on using tickets.