WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

#51225 closed defect (bug) (invalid)

WordPress 5.5.1 - all wordpress options: Reply, Quick Edit, show shortcode

Reported by: Medievaldragon Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5.1
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description (last modified by TobiasBg)

This one seems a global wordpress bug across several plugins and modules.

I went to my Tablepress to get a shortcode. That's where I first noticed the bug. (See image 1). By pressing the Shortcode link, nothing loaded. Usually there is a popup window with the shortcode that allows me to copy the code.

To test if this was an isolated Tablepress bug, I visited other wordpress functions and the bug persisted.

I visited the Comments module which is part of wordpress. Then I clicked on Quick Edit. Nothing happened. I clicked REPLY. Nothing happened. EDIT works.

So if it is a link that opens a popup or displays info within the same page, that won't show up. If the link loads a different page, then it works.

I went to another plugin named Tabs Pro. Quick edit didn't work either.

I went to PAGES which is part of WordPress. Quick Edit didn't work.

I went to POST and ALL POSTS. Quick Edit doesn't work.

I went to MEDIA in the left menu. No images were displayed. Blank page except for the wordpress left menu.

After upgrading to WordPress 5.5.1 I am also getting random errors simply by visiting all these modules within the dashboard:

"There has been a critical error on your website. Please check your site admin email inbox for instructions."

Happens once every 3-4 browsing through the modules. When I visit the next page, the error isn't repeated until next random browse to another page or module.

On another note, I am getting a random

Attachments (4)

wordpress-5-5-1-tablepress-shortcode.jpg (16.0 KB) - added by Medievaldragon 7 weeks ago.
wordpress-5-5-1-comments.jpg (94.6 KB) - added by Medievaldragon 7 weeks ago.
wordpress-5-5-1-media.jpg (66.6 KB) - added by Medievaldragon 7 weeks ago.
wordpress-5-5-1-tab-pro-quick-edit.jpg (36.3 KB) - added by Medievaldragon 7 weeks ago.

Download all attachments as: .zip

Change History (7)

#1 @Medievaldragon
7 weeks ago

Internet Browser used: Firefox 80.0.1 (64-bit)

#2 @TobiasBg
7 weeks ago

  • Description modified (diff)

Thanks for your report, and sorry for the trouble.

Most likely, you are affected by the “jQuery Migrate is disabled by default” change in WP 5.5 that is explained at https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/#post-13238244
A short-term fix might be to install the mentioned plugin from https://wordpress.org/plugins/enable-jquery-migrate-helper/ on your site.
However, this is not a real fix to the error, which is most likely raised in your theme. In more detail, some theme JavaScript file should not be using the outdated jQuery “live()” function anymore, but its replacement “on()”. You could maybe try to contact the theme support team and ask them to fix the theme.

#3 @TobiasBg
7 weeks ago

  • Component changed from General to Administration
  • Focuses accessibility removed
  • Keywords reporter-feedback needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

That said, unfortunately, this is actually not the best place to receive support for issues like this. This Trac instance is for the development of WordPress Core. For further help, I recommend that you create a support topic in the WordPress.org support forums.

I will therefore mark this thread as "invalid", which is just the unfriendly name of "not a bug in WordPress".

Note: See TracTickets for help on using tickets.