WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#51253 closed defect (bug) (invalid)

Fatal error when Updating.

Reported by: m6097 Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.5.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Hi

when I tried to update to 5.5.1, I got the following

Fatal error: Uncaught Error: Call to undefined function wp_is_auto_update_enabled_for_type() in /var/www/html/wp/wp-admin/plugins.php:570 Stack trace: #0 {main} thrown in /var/www/html/wp/wp-admin/plugins.php on line 570

I got a way out by commenting out the following lines from wp-admin/update-core.php

/*
if ( ( current_user_can( 'update_themes' ) && wp_is_auto_update_enabled_for_type( 'theme' ) ) || ( current_user_can( 'update_plugins' ) && wp_is_auto_update_enabled_for_type( 'plugin' ) ) ) {
        $help_tab_autoupdates  = '<p>' . __( 'Auto-updates can be enabled or disabled for each individual theme or plugin. Themes or plugins with auto-updates enabled will display the estimated date of the next auto-update. Auto-updates depends on the WP-Cron task scheduling system.' ) . '</p>';
        $help_tab_autoupdates .= '<p>' . __( 'Please note: Third-party themes and plugins, or custom code, may override WordPress scheduling.' ) . '</p>';

        get_current_screen()->add_help_tab(
                array(
                        'id'      => 'plugins-themes-auto-updates',
                        'title'   => __( 'Auto-updates' ),
                        'content' => $help_tab_autoupdates,
                )
        );

        $help_sidebar_autoupdates = '<p>' . __( '<a href="https://wordpress.org/support/article/plugins-themes-auto-updates/">Learn more: Auto-updates documentation</a>' ) . '</p>';
}
*/

Change History (1)

#1 @SergeyBiryukov
6 months ago

  • Component changed from General to Upgrade/Install
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Fatal erro when Updating. to Fatal error when Updating.

Hi there, welcome to WordPress Trac! Thanks for the ticket.

I'm sorry to hear you are having issues with your website. Please note that this Trac is used for enhancements and bug reporting for the WordPress core software, not for individual support questions.

It looks like the error is caused by an incomplete upgrade. The function is defined in wp-admin/includes/update.php. Reinstalling WordPress by copying all the files should fix the issue.

Please try the support forums to get help with your site: https://wordpress.org/support/forums/.

Note: See TracTickets for help on using tickets.