WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 12 months ago

#51260 closed defect (bug) (invalid)

select all checkbox not working after upgrade WP 5.5.1

Reported by: ambitusa Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: javascript, administration Cc:

Description

Select all checkbox function failed after WP5.5.1 upgraded. However, if I disable Woocommerce plugin, it was back to normal. Please refer to other forum for the same issue in the community.
https://wordpress.org/support/topic/orders-page-select-all-checkbox-not-working/

Change History (4)

#1 @SergeyBiryukov
14 months ago

  • Component changed from Query to Administration
  • Focuses javascript added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the ticket.

I'm sorry to hear you are having issues with your website since the latest update, but this topic is best discussed on the support forums or directly with the developer of your website.

Before heading there to create a post though, I recommend reading through the following list of potential issues with 5.5: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/

The most likely issue is that a plugin on your site is running old JavaScript code. I would suggest installing and activating this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

This will confirm that there is JavaScript on your site that needs to be updated to follow more modern jQuery practices. You can leave the plugin active for the time being, but the breaking code will need to be updated before the next step of the Upgrading jQuery in Core roadmap.

If this does not fix the issue, feel free to create a new support topic.

Please note that this Trac is used for enhancements and bug reporting for the WordPress core software, not for third-party plugins like WooCommerce, or individual support questions.

Feel free to reopen with the steps to reproduce on a clean install if it turns out to be an issue in WordPress core.

#2 @ambitusa
14 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Thanks for response promoptly. I did enable jquery migrate helper but no luck. It only worked selected all checkbox if I disable WooCommerce. Is there any work around tip before WP has new patch to fix the issue?

#3 @desrosj
14 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

@ambitusa if this issue only occurs when WooCommerce is active, then it needs to be reported to their team. It's possible they have already resolved this issue. Try updating the plugin to the latest version. But if that doesn't help, you can open a support request in their forum.

#4 @mike101090
12 months ago

This help me a lot, i only have the issue now with shipping methods that the checkbox still invisible

input[type="checkbox"] {
-webkit-appearance: checkbox;
}

Note: See TracTickets for help on using tickets.