WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 74 minutes ago

Last modified 6 minutes ago

#51281 closed defect (bug) (fixed)

Recent versions aren't redirecting to the correct "About" page after update

Reported by: Cenay Owned by: mikeschroder
Milestone: 5.8 Priority: normal
Severity: normal Version: 5.5.1
Component: Help/About Keywords: has-patch needs-testing
Focuses: Cc:

Description

I support a number of clients running WordPress. That last three or four updates have all experienced this problem. I recorded one such "update" today to help you understand what's happening.
https://www.screencast.com/t/astlQAypU

Recap:
Update WordPress to a new version that requires a database upgrade (or not?) and the redirect after update shows the wrong version, the wrong colors scheme and the wrong message. After the database update, if you MANUALLY revisit the About page, the content is correct.

Attachments (1)

5.5.1-update-about.png (51.0 KB) - added by pbiron 6 months ago.

Download all attachments as: .zip

Change History (16)

#1 @desrosj
6 months ago

  • Component changed from Revisions to Help/About
  • Keywords reporter-feedback added

Hi @Cenay,

Welcome to Trac! Thanks for the video showing and explaining the issue!

Are your sites running on a CDN like Cloudflare by chance? There have been a few reports of this behavior since 5.5 was released, but I believe all of them were found to be caused by some form of caching.

Also, are you sure that you refreshed that About page after updating?

#2 @pbiron
6 months ago

I can confirm I had this happen to me on a site that I updated from 5.4.2 to 5.5.1 about 2 hours ago (I've updated many other sites from 5.4.2 to 5.5 and/or 5.5.1 without an issue).

The site I updated today has no CDN, altho it is running a caching plugin (WP Fastest Cache in case it matters).

The site I updated this morning is a dev site. I plan on updating the production site later today, will report back if it happens then as well.

#3 @SergeyBiryukov
6 months ago

Just looked at the video and wanted to note that the "WordPress 5.4.2" About page initially displayed does in fact have the content from WordPress 5.5.

It's only the CSS layout and the version number that are incorrect due to some kind of caching.

#4 follow-up: @pbiron
6 months ago

5.5.1-update-about.png is the about page I got after updated the production version of the site mention in comment:2.

It's really odd. It has the 5.5.1 layout (and CSS), but the version number shown in 3 places is 5.4.2, but correctly shows 5.5.1 in the "Maintenance and Security Releases" section.

The other odd thing is that the "WordPress 5.5.1 is available! Please update now." links are displayed at the top, even tho the update has already happened.

#5 in reply to: ↑ 4 @SergeyBiryukov
6 months ago

Replying to pbiron:

It's really odd. It has the 5.5.1 layout (and CSS), but the version number shown in 3 places is 5.4.2, but correctly shows 5.5.1 in the "Maintenance and Security Releases" section.

That section is hardcoded, so not quite relevant here :).

It looks like get_bloginfo( 'version' ) returns outdated info for some reason, could be an object caching issue.

This ticket was mentioned in Slack in #core-auto-updates by pbiron. View the logs.


6 months ago

#7 @pbiron
6 months ago

Could this be related to #36455?

#8 follow-up: @SergeyBiryukov
5 months ago

At a glance, I think [48160] / #36455 was supposed to fix issues like this, rather than introduce them, but some more testing in an environment where this can be easily reproduced would definitely be helpful.

#10 in reply to: ↑ 8 @mikeschroder
4 months ago

Replying to SergeyBiryukov:

At a glance, I think [48160] / #36455 was supposed to fix issues like this, rather than introduce them, but some more testing in an environment where this can be easily reproduced would definitely be helpful.

Yes, it was. Would love to catch / fix any cases missed there.

#11 follow-up: @stodorovic
3 days ago

@mikeschroder I just saw similar behavior while I'm updating 5.6.1 to 5.6.2. Only wp-includes/version.php isn't invalidated. When I remove "opcache file" (if opcache.file_cache is enabled):
rm ~/.opcache/d233b18c979d5b5914d959191fc8d11c/home/test/public_html/wp-includes/version.php.bin
then "about page" shows correct version.

#48160 doesn't invalidate version.php because it's copied later (by $wp_filesystem->copy). I think that https://github.com/WordPress/wordpress-develop/pull/976 fixes this issue.

#12 in reply to: ↑ 11 @mikeschroder
33 hours ago

  • Keywords has-patch added; reporter-feedback removed
  • Owner set to mikeschroder
  • Status changed from new to assigned

Replying to stodorovic:
<snip>

#48160 doesn't invalidate version.php because it's copied later (by $wp_filesystem->copy). I think that https://github.com/WordPress/wordpress-develop/pull/976 fixes this issue.

Thank you -- really good catch! Yes, I agree, looks like this case was missed.
I'll work up a commit.

Apologies, I missed your comment on the other ticket.
I suspect this will fix both #51686 and this ticket.

#13 @mikeschroder
9 hours ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 5.8

#14 @mikeschroder
74 minutes ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 50475:

Upgrade/Install: Invalidate OPcache for version.php during update.

Invalidate OPcache for wp-content/version.php on update individually, since it’s copied separately.

Props stodorovic, krstarica, cenay, desrosj, pbiron, sergeybiryukov, mikeschroder.
Fixes #51686, #51281.
See #36455.

#15 @mikeschroder
6 minutes ago

In 50477:

Upgrade/Install: Invalidate OPcache for version.php during update.

Invalidate OPcache for wp-content/version.php on update individually, since it's copied separately.

Props stodorovic, krstarica, cenay, desrosj, pbiron, sergeybiryukov, mikeschroder.

Reviewed by mikeschroder, SergeyBiryukov.
Merges [50460] and [50475] to the 5.7 branch.
Fixes #51686, #51281.
See #36455.

Note: See TracTickets for help on using tickets.