WordPress.org

Make WordPress Core

Opened 6 days ago

Closed 3 days ago

#51297 closed defect (bug) (invalid)

The new WordPress 5.5.1 create 600ms TTFB respund

Reported by: 123nadav Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5.1
Component: General Keywords:
Focuses: performance Cc:

Description

Hey hello, how are you guys?
after a lot of optimization and chacks, we find out the core has an issue with TTFB.
the old version 5.5 the first one was with TTFB 0.08
sometimes jump to 0.12 but it was amazing performance...

the last update 5.5.1 before week ago destroy everything... more 600ms
you can check in page speed i have 3 identical sites and one is without tag manager for
testing performance:
locksmithunit.com
locksmithunit.cat - no tag manager - more fast - for testing
locksmithunit.es

i tried with the THEME DEVELOPER even to change the THEME to WordPress THEME.
(like twenty twenty).

but still without any plugin after restart + refresh cpanel server
nothing work... the issue is in the core...
i even tried another server but the problem is the same...
the core of WordPress 5.5.1 or something there is blocking and create TTFB of 600
more from the older version (the first 5.5 was the best)

you can check the site in page speed, and see.
My sites don't have any error...
All of them fully optimize, with server c-panel NGINX for high performance.

I hope the fix will come soon and you will come back to TTFB of 0.08,
like one version before 5.5.1.

Regards,
Nadav Levi Yahel
Locksmith Unit

Change History (6)

#1 @peterwilsoncc
5 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed

@123nadav

Hello and welcome to trac!

I've done some testing between version 5.5 and 5.5.1 on a local virtual machine with a little under 600 posts and can not reproduce the problem on a vanilla install of WordPress (default theme, no caching, no plugins).

Using a utility to measure time to first byte over 200 requests showed no significant performance difference.

// 5.5.1
$ bash ~/Downloads/ttfb.sh -n 200 http://wordpress-develop.local/
........................................................................................................................................................................................................
fastest .091106 slowest .137703 median .096078


// 5.5
$ bash ~/Downloads/ttfb.sh -n 200 http://wordpress-develop.local/
........................................................................................................................................................................................................
fastest .090222 slowest .161712 median .097094

I repeated the test a number of times and there was a little variation on each run but no difference like the one you describe.

I'm going to close this ticket as works for me, indicating the problem could not be reproduced. You may wish to visit the support forums for further assistance with your site.

#2 follow-up: @123nadav
5 days ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hey, how are you?
Thank you for your Attension i appreciate that.
So... First of all, the 5.5.1 slowest in 1000 MORE, and generally your test shows the 5.5 is better, is MEAN I AM RIGHT, and something is wrong here...

How is even possible the older version, is better from the new one?
even in 1 point?
is not make sense, is an upgrade or downgrade?
something is wrong and i am sure 99.9%.

Now measurement is from server to server.
With your test, i see 5.5 is better already from 5.5.1...

I recommended you will do the test on Pagespeed and not from the SSH or any command-line...
we now try to solve the Pagespeed issue ( Pagespeed is the most important test today, any website and even WordPress need to be compiled to this test... ) test via command line not rendering the site is not a reasonable test to our problem... especially when you chack # and any server use nginx can provide false data or data without apache.

if the issue is serious i even not care to purchase premium support from the WordPress team about
the issue.
( even i know i am 100% right after all the test i did. and i am sure this comes from 5.5.1 core files ).

This test you, showing me is not efficient... is not a way to test something like that for the Pagespeed test.

NOW, I KNOW YOU GOING TO SAY IS THE BEST WAY TO CHECK, BUT GOOGLE CHANGE THE GAME, AND THE CORE TEST IS CURRENTLY NOW INSIDE THE "GOOGLE SEARCH CONSOLE" AS WELL, AND OF COURSE THEY CONNECTED TO THE PAGESPEED URL TEST TO THAT.

You must create 2 websites... with different THEME and with the same (3 - 4) and test them throw page speed URL and not the browser TEST, browser test show sometimes HIGHER Cache result and this is not the real result of the WORDPRESS CORE.

I assure you, i chack that more than several times with all my developer and the THEME developer ( all my site is premium plugins and premium THEME )

i am a developer by myself self and i design + development all the websites the server and the graphic...
you can run a test in page speed you will see i don't have even a warning... my sites are very advance and i work on them 3 years 24/7.... if i come to here and open a ticket, believe me, i know WordPress 5.5 is better then his update in 100%.

Please, i am asking you, if you can diagnose the issue of the core AGAIN.

Is not possible to get 600ms more exactly after the update to 5.5.1.
The damage is critical and DESTROY SEO and even PPC with the new POLICY of Google...

Like you know already, Google, demands today to be fully optimized.
Google even said they going to buy WordPress soon. (if not buy it already and i am not updated).

We must follow google... i believe WordPress does and know that as well...

END FOR THE FINAL :-)

Thank you for your Attension, sorry if my English is bad and something is not clear.
But is very important to me, and like i said i know 99.9% the issue is from the core.

I don't care to invest in WordPress Team to fix the issue or any other solution.
I love WordPress i think is the best investment can to be and if i can to be involved i be more then
happy to help in something like that, with my knowledge and even with investment (if needed).

Best Regards,
Nadav Levi Yahel
Locksmith Unit

Last edited 5 days ago by 123nadav (previous) (diff)

#3 in reply to: ↑ 2 @SergeyBiryukov
5 days ago

  • Keywords close added
  • Milestone set to Awaiting Review

Hi there, thanks for the ticket.

I'm sorry to hear you are having issues with your websites since the latest update. Unfortunately, it doesn't look like there are any actionable items for WordPress core here, as Google PageSpeed results depend on many various factors.

Replying to 123nadav:

But is very important to me, and like i said i know 99.9% the issue is from the core.

Here's the full list of changes in 5.5.1. If you can identify a performance issue with a specific change, please feel free to comment and provide some more information, so that the issue could be investigated further.

Until the issue is identified, confirmed, and can be reproduced with some steps on a clean install in more than one environment, this topic is best discussed on support forums.

Last edited 5 days ago by SergeyBiryukov (previous) (diff)

#4 @123nadav
5 days ago

Ok first how are you,
we sure are from the core because when is start, i was needed to use the jquery test tool from the WordPress team.

we activate him to see if we got something.

on the site, we didn't get anything...
on the Google search console we start to get the excellent green score...
(is not something normal very rear to get green, especially with the core of WordPress..)

I have 3 sites so we try JQmigrate helper tool from the WordPress team (wordpress.com or org is you guys)

We start to get a different result in google CORE TEST in the google search result...

screenshots:
https://ibb.co/bmsfqQd
https://ibb.co/Zhw3jX5

This is 2 sites identicaL in everything.
But!
Because your tool (the core test tool), the google search core test is shifting.

Now, this test is not the page speed test...
you can get inside the instruction pages of the google search console.

They even aware the core problem in WordPress for over the years...and see this test working of the core.
new management from google.
something WordPress must be compile.

i even tried to call my THEME developer in Romania and we diagnose the issue as well several times with different THEME (we chose a WordPress THEME, like twenty twenty)

we even tried different servers without Nginx, but all the time we get this TTFB in google page speed, and the core test not stable...

all of that if you look on my screenshot, hepend exactly after the 5.5.1 update, you can look on the dates.

You right, is not something we can diagnose like that.
My only hope is will change in the next week.
(have a new version, on your page 5.6 or 5.5.something...)

You can keep this ticket open?
If something will change, i will create SNAPSHOT / BACKUP and update here in the ticket, i think is the best diagnostic we can get.

By the way.
I can provide you my websites or put "Locksmith Unit" in google ( i don't want to publish links here is will cause a violation in the ticket ).

I said that for diagnostic of course... but i will not lie and you give here
a good point as well, especially after i look on the updates.. is will not help.
but if you want, i can provide my websites if you do not see them already.

If you can, keep the ticket open, i will update in a week when the new version comes out here in this ticket and we follow step by step. ( if is possible of course )

Thank you everybody for the help.

Regards,
Nadav Levi Yahel
Locksmith Unit

Last edited 5 days ago by 123nadav (previous) (diff)

#5 @123nadav
3 days ago

I fix it. is not WordPress is was Nginx after a lot and a lot of tests
I was must activate memcache with the new wordpress and server client cache
and now i dont have TTFB respond at all:
https://developers.google.com/speed/pagespeed/insights/?hl=en&utm_source=wmx&utm_campaign=wmx_otherlinks&url=https%3A%2F%2Flocksmithunit.com%2F&tab=desktop

full optimize :)

I AM SORRY AGAIN, YOU CAN CLOSE THE THREAD.

Last edited 3 days ago by 123nadav (previous) (diff)

#6 @SergeyBiryukov
3 days ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.