Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#51322 closed defect (bug) (invalid)

Upgrading from 5.4.2 to 5.5/5.5.1 gives multiple problems

Reported by: torqueing's profile torqueing Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.5
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

After upgrading to the 5.5 series of WordPress there are several problems:

  1. the icons from the classic editor disappear and it's impossible to switch from text editing and visual editing. There are also problems with the Gutenberg editor.
  2. Sub menus don't display when you hover the cursor over them and only appear *after* you have clicked on the menu item itself.
  3. The 'select-all' checkbox in the plugins section doesn't select any plugins, it just checks its own box

I have created a couple of cloned website for you to see the difference. I have also tested the problem with the WP-Downgrade plugin and the problems disappear when downgrading to 5.4.2. Please ask if you need access to the back end to test for yourself

Change History (1)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the ticket.

I'm sorry to hear you are having issues with your website since the latest update, but this topic is best discussed on the support forums or directly with the developer of your website.

Before heading there to create a post though, I recommend reading through the following list of potential issues with 5.5: https://wordpress.org/support/topic/read-this-first-wordpress-5-5-master-list/

The most likely issue is that a plugin on your site is running old JavaScript code. I would suggest installing and activating this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

This will confirm that there is JavaScript on your site that needs to be updated to follow more modern jQuery practices. You can leave the plugin active for the time being, but the breaking code will need to be updated before the next step of the Upgrading jQuery in Core roadmap.

If this does not fix the issue, feel free to create a new support topic.

Please note that this Trac is used for enhancements and bug reporting for the WordPress core software, not for individual support questions.

Feel free to reopen with the steps to reproduce on a clean install if it turns out to be an issue in WordPress core.

Note: See TracTickets for help on using tickets.