Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#51337 closed defect (bug) (fixed)

Twenty Twenty: Custom Logo bug in the Customizer

Reported by: acosmin's profile acosmin Owned by: hellofromtonya's profile hellofromTonya
Milestone: 5.9 Priority: normal
Severity: normal Version: 5.5
Component: Bundled Theme Keywords: has-patch has-testing-info commit
Focuses: Cc:

Description

This ticket is based on a bug discovered by @ilovewpcom

 I think I found a weird bug in the theme. It's not breaking anything, just some odd behaviour.

 Steps to replicate the issue:
 1. Start with a website that doesn't have a logo in the Site Identity.
 2. Open the Customize page and open the Site Identity panel.
 3. Upload a logo and DON'T click the Publish button.
 4. Change the site title or description under the logo.

 Right after step 4 you will notice that the logo disappears in the previewer and the site title becomes a lot bigger.
 If you click the Publish button to save the changes then everything is correct on the front-end.
 The only issue is with the previewer's odd behaviour.
 I hope this helps :)

A solution for this is to add:

'container_inclusive' => version_compare( $GLOBALS['wp_version'], '5.5', '>=' ),

on class-twentytwenty-customize.php:L50

It probably needs more testing.

Attachments (1)

51337.patch (818 bytes) - added by sabernhardt 3 years ago.

Download all attachments as: .zip

Change History (11)

@sabernhardt
3 years ago

#1 @sabernhardt
3 years ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to 5.9

Thanks for the report!

I reproduced the error in Twenty Twenty with several earlier WordPress versions, going back to the minimum version (4.7):

5.8
5.4.6
5.3.8
5.0.13
4.9.18
4.8.17 (with WP_DEBUG set to false)
4.7.21 (WP_DEBUG false again)

So this probably does not need to check the version, and container_inclusive seems to fix it.

Note: I did not experience the same problem with other bundled themes, from Twenty Fifteen to Twenty Twenty-One (using WP 5.8).

#2 @Boniu91
3 years ago

  • Keywords has-testing-info added

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


3 years ago

#4 @Boniu91
3 years ago

Working as expected.

Test Report

Env

  • WordPress 5.9-alpha-51272-src
  • Theme: Twenty Twenty and Twenty Twenty One

Steps to test

  1. Use Twenty Twenty
  2. Go to customizer choose Site Identity section
  3. Upload logo
  4. Change the Site Title
  5. Play around with adding/removing logo, changing Title and Description in order to find other glitches

Expected behaviour:
Logo doesn't disappear

This ticket was mentioned in Slack in #core by chaion07. View the logs.


3 years ago

#6 @chaion07
3 years ago

Hi @acosmin! Thank you for reporting this. Since discussing this recently during a bug-scrub session we feel that this testing is sufficient. Our team would still test this to confirm and get this ready for Commit. Cheers!

#7 @sabernhardt
3 years ago

  • Keywords commit added; needs-testing removed

#8 @hellofromTonya
3 years ago

  • Owner set to hellofromTonya
  • Status changed from new to reviewing

Assigning to myself to prepare the commit.

#9 @hellofromTonya
3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 52022:

Bundled Theme: Ensure logo displays in Customizer previewer.

Fixes an issue with the logo not displaying the Customizer previewer when changing the site title or description.

Follow-up to [46271].

Props acosmin, boniu91, sabernhardt.
Fixes #51337.

#10 @hellofromTonya
3 years ago

Thank you everyone for contributing. The fix has been committed and will ship with WordPress 5.9.

Note: See TracTickets for help on using tickets.