WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#51345 closed enhancement (duplicate)

Multisite confusion with adding plugins

Reported by: stormrockwell Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: multisite Cc:

Description

If you are a super admin on a site, instead of hiding the "Add New" plugin button, it would be a better experience to show a message or button that can help lead you to the network plugins area.

Issues:

  • I work a lot on multisite installs, but I constantly click plugins on the site I'm on, and my first thought is, "Why is the Add New button missing?" before I realize I'm not on the network.
  • I get a lot of tickets from newer multisite admins thinking there are file permission issues/don't have access because they forget they need to add plugins at a network level

Ideas:

  • Add a button: "Add Plugin To Network." on sites if the user is a super admin.
  • Add a message that doesn't call as much attention. Possibly something like: "New plugins must be <a href="">added to the network</a>" on sites if the user is a super admin.

I figured I'd start this as a discussion, and I can make a patch if others think it would be helpful. I definitely stumble across this a lot.

Change History (2)

#1 @johnbillion
5 months ago

  • Component changed from General to Plugins
  • Focuses multisite added

#2 @jeremyfelt
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket, @stormrockwell. I'm going to close this as a duplicate of #24866, where quite a bit of discussion around this exists. I would recommend reading through that and chiming in with any comments. Also related: #31659.

Also from that ticket, a plugin which may help for the time being: https://wordpress.org/plugins/multi-site-plugins-add-new/

Note: See TracTickets for help on using tickets.