Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#51357 closed defect (bug) (duplicate)

Some core strings appear to not be localized

Reported by: carike's profile carike Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: ui, administration, ui-copy Cc:

Description

How to replicate:
Switch installation's language to Afrikaans.
Under the Posts -> Categories sub-menu, you'll see "uncategorized".
I searched the 5.5.x development sub-project and the string has been translated: https://translate.wordpress.org/projects/wp/dev/af/default/?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=1240&filters%5Btranslation_id%5D=46701298

Change History (2)

#1 @garrett-eclipse
4 years ago

  • Keywords close added

Hello @carike before closing as duplicate of #51203 could you check if you installed it using Afrikaans or switched to Afrikaans post-install?
The category is generated during the installation process so will conform to the locale used then. If you later switch your language WP won't update the categories as that would potentially break your install. You'd have to manually change the term when you change the language.
Hope that makes sense and let me know if it's not aligning with your circumstance.

#2 @carike
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #51203.

I did switch afterwards (but before creating any posts on the test site) to help someone with an issue on the forums :)

Just noting that some quick-installers have a limited language selection, so in some cases, it may not be possible for ordinary users to choose their preferred language on installation.

Last edited 4 years ago by carike (previous) (diff)
Note: See TracTickets for help on using tickets.