Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#51404 closed defect (bug) (invalid)

'Change logo' button in customizer doesn't work in Firefox

Reported by: majorlabel's profile majorlabel Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords: reporter-feedback
Focuses: Cc:

Description

Using firefox 81.0, going into the customizer > site identity and clicking the 'change logo' button, nothing happens. No console error, no network activity. Doing the exact same thing in chrome opens the filepicker.

Change History (5)

#1 @mukesh27
4 years ago

  • Keywords reporter-feedback added

Hi there, Welcome to WordPress Trac! Thanks for the ticket.

I can't replicate same issue in fresh install. All media popup working fine.

Please share more information to replicate the issue

#2 @majorlabel
4 years ago

This appears to be a CSS issue. I now have the same issue in Chrome. Clicking the button does fire JS. For instance, the body gets the 'modal-open' class. I don't know where the modal lives in the DOM so hard to debug. Could the theme CSS be loaded in this window?

#3 @majorlabel
4 years ago

Thanks for the great support so far. I can confirm this is a CSS issue. The .media-modal receives too little CSS from load-styles.css. This only happens in the customizer, not in other places.

#4 @majorlabel
4 years ago

I opened a recent local copy of the wordpress installation where I have this issue on. There the media modal does work, and the CSS is loaded through

load-style.php

I've noticed on this installation that the auto-updater botches files due to, what seems to be encoding issues. Can someone please help on how to debug this specific part of wordpress? I am a developer but not very knowledgeable when it comes to WordPress development.

#5 @dlh
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.5.1 deleted

Hi @majorlabel,

Unfortunately, support for individual installations isn't available in Trac, but you'll be able to find help in the WordPress support forums.

If it turns out there is a bug in autoupdates that leads to this issue in the Customizer, it would be best to open a dedicated Trac ticket for that in the upgrade component.

For now, as there doesn't appear to be an issue in the Customizer (I am also unable to replicate it in Firefox 81 on a fresh installation with a default theme), I'm going to close this ticket, but feel free to reopen it if steps to replicate the issue reliably can be developed.

Note: See TracTickets for help on using tickets.