WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 12 years ago

#5144 closed defect (bug) (worksforme)

Paragraph end-tag wrongly inserted after object tag

Reported by: jameslab6 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: General Keywords: paragraphs formatting
Focuses: Cc:

Description

The following code typed into Wordpress:

<div style="text-align: center; margin: auto">
<object type="application/x-shockwave-flash" style="width:425px; height:353px;" data="http://www.youtube.com/v/u-foWh9dskg">
<param name="movie" value="http://www.youtube.com/v/u-foWh9dskg" />
</object></div>

is rendered as:

<div style="text-align: center; margin: auto">
<object type="application/x-shockwave-flash" style="width:425px; height:353px;" data="http://www.youtube.com/v/u-foWh9dskg"></p>
<param name="movie" value="http://www.youtube.com/v/u-foWh9dskg" />
</object></div>

Notice the </p> just before the start of the <param> tag. This renders the XHTML invalid.

Attachments (1)

ParagraphBug.txt (817 bytes) - added by jameslab6 14 years ago.

Download all attachments as: .zip

Change History (3)

#1 @jameslab6
14 years ago

(I have attached the content of this bug report as a text file just in case the spacing is not preserved by Trac and it turns out to be important).

#2 @mrmist
12 years ago

  • Milestone 2.9 deleted
  • Priority changed from high to normal
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Worksforme in trunk. (no closing p tag)

Re-open if it can still be reproduced in 2.7.

Note: See TracTickets for help on using tickets.