WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 4 weeks ago

Last modified 4 weeks ago

#51442 closed defect (bug) (invalid)

Cannot add youtube links since Gutenberg update to 9.1.0

Reported by: yeoric Owned by:
Milestone: Priority: normal
Severity: major Version: 5.5.1
Component: Editor Keywords:
Focuses: Cc:

Description

Since this Gutenberg plugin update any attempt to add a youtube link - via video block, youtube block, Custom HTML iframe (iframe code copied from Youtube post Share function), normal link in paragraph, even just copying the link text into a paragraph block (without actually making it a link - though I suspect the editor may try to do this automatically) results in a json error and, in case of embed blocks, a "you cannot embed this" error (which I think is a follow-up error). Links to other sites work as expected.
Existing pages continue to work but cannot be updated. The error seems to be theme- and plugin-independent.
If you need additional information please advise how to get them. As far as WP is concerned I am strictly at user level, though I am a software engineer.

Change History (10)

#1 @yeoric
2 months ago

Hm. I feel a bit silly now. I went to Classic to edit a post, and then switched back to Gutenberg. And you know what: Everything worked just fine again. No idea what happened and whether the switch was the "repair" or what caused Gutenberg to work again.

#2 @yeoric
2 months ago

But then it happened again. I worked on a page for a while, all was well, and then added a new embed block on the page - wham. Same as before: "Could not embed", JSON error etc. , and it was not Youtube's fault - I had the same block on the same page before, removed it and then decided I'd add it again in a different place on the page. Switched to Classic editor, no problem editing + saving the page there. Back to Gutenberg - same error.
Something is definitely wrong here.

#3 @yeoric
2 months ago

Sorry, read "post" for "page" throughout.

#4 @yeoric
2 months ago

I am beginning to suspect that this may indeed be not a functional error but a case of wrong error message, like (just an example) translating a timeout error because of a slow network connection into a completely misleading error message. Juts now it works again …

#5 @yeoric
2 months ago

OK, last update, I hope. Problem persists. I re-checked with default theme and all plugins off (did that before, but did it again just to be sure).
I managed to add 4 embed blocks with youtube videos (2 50:50 columns blocks with 2 videos each). This worked, after a few tries. I failed consistemtly when trying to add another columns block and adding videos, or even when trying to add a paragraph containing a youtube link (as before); Gutenberg would throw the JSON error and would not update.
I created another post using Gutenberg, with 1 columns block, as I tried above. Switched to Classic, copied the block in text mode, included this in the original post, updated.
Post now shows all 6 videos as intended (3 rows of 2 veideos each). Gutenberg still cannot update the block and *immediately* shows "You cannot embed this …" for each video, plus the JSON error, the moment I edit the post.
Workaround found. Contact me if there are any q.s or if you need site access.

#6 @yeoric
2 months ago

Oomph. The real problem seems to lie in a completely unexpected place. My provider hosting WordPress is Strato (strato.de), and they seem to have a security feature in place that I did not connect with WordPress. See here: https://wordpress.org/support/topic/updating-failed-error-message-the-response-is-not-a-valid-json-response/page/3/#post-13497799 . Their "guestbook spam filter" seems to filter post and page updates if they come from Gutenberg (not if they come from the Classic editor).
The question remains: Why would WordPress send updates from the block editor in a format that could conceivably mistaken for a post or guestbook entry?
I communicated the problem to Strato, but without much hope for change.

#7 @yeoric
8 weeks ago

I got a confirmation from STRATO. The main point was that their abovementioned spam filter replies with a 503 "Service unavailable" message in cases of suspected spam. But in the WP/Gutenberg editor GUI this comes back to me as the JSON error mentioned above. It looks like my initial assumption about a completely misleading error meessage was not very far off the mark. A 503 message would have put me right on track where to look, i. e. at the hosting server.

#8 @sabernhardt
7 weeks ago

  • Component changed from General to Editor

#9 @SergeyBiryukov
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the report.

It looks like this was an issue with anti-spam filters on a specific hosting platform, so there are no actionable items for WordPress core here.

If you have any suggestions on improving the error message displayed in this case, please submit them to the Gutenberg repository on GitHub: https://github.com/WordPress/gutenberg/.

#10 @yeoric
4 weeks ago

Well yes, there is concrete request: Do give a correct error message. If you receive a 503 error do not report a JSON error.

Note: See TracTickets for help on using tickets.