WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 8 months ago

#51460 closed task (blessed) (duplicate)

REST API: Add sidebars & widgets endpoints

Reported by: TimothyBlynJacobs Owned by: TimothyBlynJacobs
Milestone: Priority: high
Severity: normal Version: 5.0
Component: REST API Keywords:
Focuses: Cc:

Description

This is a tracking ticket for merging the sidebars and widgets endpoints from Gutenberg.

https://github.com/WordPress/gutenberg/blob/master/lib/class-wp-rest-sidebars-controller.php

This one still requires some work to split up the sidebars controller.

Change History (8)

#1 @TimothyBlynJacobs
15 months ago

  • Priority changed from normal to high

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


15 months ago

#4 @TimothyBlynJacobs
15 months ago

  • Milestone changed from 5.6 to 5.7

Punting to 5.7 as #51506 won't be shipping in this release.

This ticket was mentioned in Slack in #core-restapi by timothybjacobs. View the logs.


15 months ago

This ticket was mentioned in Slack in #core by lukecarbis. View the logs.


13 months ago

#7 @noisysocks
13 months ago

  • Milestone changed from 5.7 to Future Release

Moving this to Future Release as this feature isn't specifically targeting 5.7.

#8 @TimothyBlynJacobs
8 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #41683.

Note: See TracTickets for help on using tickets.