Make WordPress Core

Opened 4 years ago

Closed 13 months ago

#51484 closed defect (bug) (worksforme)

A meta box can be prevented from being returned to its original position

Reported by: johnbillion's profile johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: close needs-patch
Focuses: javascript, administration Cc:

Description

Given a site with an advanced meta box and a side meta box on the post editing screen, if the side meta box is moved into the advanced position it's not possible to move it back to the side. Tested both with drag and drop and by clicking the up/down position arrows introduced in 5.5.

Steps to reproduce:

  1. Add the following to a plugin:
add_action( 'add_meta_boxes', function() : void {
	\add_meta_box(
		'test-advanced',
		'Advanced',
		function() {
			echo 'Advanced';
		},
		'post',
		'advanced'
	);
	\add_meta_box(
		'test-side',
		'Side',
		function() {
			echo 'Side';
		},
		'post',
		'side'
	);
} );
  1. Load the post editing screen and confirm one advanced and one side meta box are present.
  2. Move the side meta box into the advanced section, either by clicking its "up" arrow or by dragging and dropping it.
  3. Reload the post editing screen (required step).
  4. Observe that it's not possible to move the side meta box back to the sidebar. It can't be dragged into the sidebar, and its down button is disabled.

This does not affect the classic editor, even if you're silly enough to move all the side meta boxes over into the advanced section.

Change History (4)

#1 @johnbillion
4 years ago

  • Summary changed from A side meta box can be prevented from being returned to the side to A meta box can be prevented from being returned to its original position

Update: The opposite is true too. If you move the advanced meta box into the side and reload the page, it cannot be moved back.

#2 @Frykky
3 years ago

I think i found the same bug.

I have 3 metaboxes under the content in page editor:
1)Yoast
2)WPML
3)ACF group field for post_type=page

I move 3 metaboxes to right pane and now it seems impossible to move back under content.

#3 @lopo
14 months ago

  • Keywords close added

Looking at it during the Contributor Day at WordCamp Europe 2023

I cannot reproduce anymore on 6.2.2. @johnbillion do you think this is still relevant?

#4 @johnbillion
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

👍

Note: See TracTickets for help on using tickets.