Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 23 months ago

#51568 closed defect (bug) (fixed)

Random cookie test failures

Reported by: sergeybiryukov's profile SergeyBiryukov Owned by:
Milestone: 6.1 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

Background: #48145, #50466, #51109.

A random test failure started appearing recently, on the week of October 12th:
https://travis-ci.com/github/WordPress/wordpress-develop/jobs/402008647

There was 1 failure:

1) Tests_HTTP_Functions::test_get_response_cookies_with_wp_http_cookie_object
Failed asserting that an array is not empty.

/var/www/tests/phpunit/tests/http/functions.php:140

This job has the output of the response that might be helpful:
https://github.com/WordPress/wordpress-develop/runs/1275594522?check_suite_focus=true#step:19:1

Change History (5)

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


4 years ago

#2 @SergeyBiryukov
3 years ago

  • Milestone 5.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This has not happened recently, it looks like the issue has fixed itself for now.

This ticket was mentioned in Slack in #core by sergey. View the logs.


23 months ago

#4 @SergeyBiryukov
23 months ago

In 53491:

Tests: Use a consistent URL in HTTP response cookie tests.

Follow-up to [34369], [35734], [38164].

See #51568.

#5 @SergeyBiryukov
23 months ago

  • Milestone set to 6.1
  • Resolution changed from worksforme to fixed

It looks like this was caused by occasional unexpected output from the HTTP request to http://example.org.

[53491] appears to have stabilized the results.

Note: See TracTickets for help on using tickets.