WordPress.org

Make WordPress Core

#51598 closed defect (bug) (fixed)

Can no longer update plugins via Update page (5.6 beta1)

Reported by: ahortin Owned by: SergeyBiryukov
Milestone: 5.6 Priority: normal
Severity: critical Version: 5.6
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

I've just updated to the latest nightly (5.6-beta1-49267) and I can no longer update any plugins via the update page (/wp-admin/update-core.php).

After selecting the plugins and clicking Update Plugins, the page refreshes but just doesn’t update anything.

Vid: https://share.getcloudapp.com/xQuAqD2o

Change History (4)

#1 @dd32
13 months ago

  • Component changed from General to Upgrade/Install
  • Milestone changed from Awaiting Review to 5.6
  • Version set to trunk

Looks like this is caused by [49254] - The form is lacking a </form> and so the <form> for the plugin update section is ignored by the browser, effectively causing the submit buttons on the plugin update to save the major autoupdate option instead.

#2 @afragen
13 months ago

I can confirm that adding the </form> does fix the issue.

See https://core.trac.wordpress.org/ticket/50907#comment:69

#3 @afragen
13 months ago

  • Severity changed from normal to critical

#4 @SergeyBiryukov
13 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 49274:

Upgrade/Install: Add missing </form> tag in auto-updates settings form.

Props imath, ahortin, dd32, afragen.
Fixes #51598. See #50907.

Note: See TracTickets for help on using tickets.