WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 2 months ago

#51615 closed defect (bug) (fixed)

Twenty Twenty-One Customizer: Editing Footer menu changing URL causes duplication in the preview

Reported by: garrett-eclipse Owned by:
Milestone: 5.6 Priority: normal
Severity: normal Version: 5.6
Component: Bundled Theme Keywords: has-screenshots
Focuses: ui, administration Cc:

Description

When you edit the URL of a footer item in the Customizer Menu the icons start duplicating and getting edit icons on them. I assume the edit icons should always be there and the existing icons should update.

In my test I was changing the Facebook item to Linkedin.

Steps to produce;

  1. Install beta.
  2. Customizer > Menu
  3. Choose Footer Menu.
  4. Edit the Facebook item and change it's URL.
  5. View the preview icons get duplicated.

Attachments (1)

225d0f4ce24bc66fcf3d80e0a815fed9.gif (622.4 KB) - added by garrett-eclipse 3 months ago.
Screen walkthrough illustrating the issue.

Download all attachments as: .zip

Change History (7)

@garrett-eclipse
3 months ago

Screen walkthrough illustrating the issue.

#1 @joyously
3 months ago

I think it's because it's a partial. When I try the social menu in Twenty Twenty, it doesn't show the edit icon at all.

This ticket was mentioned in Slack in #core-themes by hellofromtonya. View the logs.


3 months ago

#3 @helen
2 months ago

  • Component changed from Themes to Bundled Theme
  • Milestone changed from Awaiting Review to 5.6

Milestoning for visibility.

#4 @poena
2 months ago

I did test this earlier and was able to reproduce it with the version of the theme that is included in 5.6-beta3-4956.

But when testing 5.6-beta3-49562 with the latest version of the theme from the GitHub repository, I can not reproduce it.

There is a visible refresh of the customizer when I change a menu item, but the footer menu does not have a Customizer shortcut icon and the menu items are not being duplicated.

This ticket was mentioned in Slack in #core-themes by hellofromtonya. View the logs.


2 months ago

#6 @hellofromTonya
2 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Following @poena's strategy, I too cannot reproduce it with 5.6-beta3-49562 with the latest version of the theme from the GitHub repository.

Closing this ticket as fixed.

@garrett-eclipse please test. If able to reproduce, please reopen.

Note: See TracTickets for help on using tickets.