WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#51627 closed defect (bug) (invalid)

Reddit Embeds Broken

Reported by: AdvancedWarfare Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Embeds Keywords:
Focuses: javascript Cc:

Description

Dear Support,
As per this forum post: https://wordpress.org/support/topic/reddit-embeds-not-triggering/#post-13577599

Reddit video embeds seem to shows, flicker, and then not display anything at all. Another user has confirmed this to be the case on the forum post.

I have tested this with no plugins activated and the 2020 theme and it is still the case.

The embed was placed in the post using the native WP / Embedly method of copy + pasting the URL.

Example: https://gamingintel.com/warzone-player-hides-in-bathtub-to-trick-enemy-squad/

Change History (1)

#1 @Clorith
6 months ago

  • Focuses ui accessibility performance removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Version changed from 5.5.1 to 4.0

Hiya,

This looks to be an issue on the side of Reddit.

A quick look shows that the embed is working like it should, as images show as expected.

The reason you see the flicker is because the thumbnail for the video is loaded first (an image, which works), but then the JavaScript meant to load the video player is loaded, and it has a fatal error, so it can't show the video box, it just disappears, but the embed it self is still there (the box with the frame for a vide4o, and the description).

Basically, Reddit needs to fix their oEmbeds, from a quick search, it seems they've had some issues over the past few years, with their embeds failing from time to time (I would link sources, but most folks reporting them used inappropriate language in their posts, so I will leave that to each individuals own desire to look it up), so it may just be that you need to reach out and let them know that you use their service and it had a failure.

I'm closing this as invalid (it's the most appropriate ticket status), not because your problem isn't valid, but because the problem lies with the provider, Reddit, and not WordPress it self.

Note: See TracTickets for help on using tickets.