Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5165 closed defect (bug) (duplicate)

Installs fail due to PHP memory requirements

Reported by: MichaelH Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:


Beginning with 2.3, have run into a number of installations that fail due to not having enough memory allocated to PHP. Typically, increasing PHP memory to 16M (from 8M) solves the problem. Should the requirements be revised to reflect this?

The error presented is either an Internal Server Error 500 or a Fatal error: Allowed memory size of 8388608 bytes exhausted.

As an example, with the host doteasy.com, a request to increase PHP memory must be addressed to their support department before WordPress can be installed.

Also, note this Forum thread regarding an upgrade to 2.3:

Change History (8)

#1 @santosj
8 years ago

What version of PHP are you using?

#2 @MichaelH
8 years ago

Good question--should have reported that before!

Two hosts that I can remember
Doteasy.com uses 5.0.4
Evolink.ro uses 5.2.0

#3 @santosj
8 years ago

In some version of PHP 5.2.x, there were corrections to the memory management. In that the real (or as accurate as possible) usage is being reported and the memory usage is advised to be increased anyway to at least 16MB because of the fix.

However, this wouldn't be the case for PHP 5.0.x, so that is interesting. Very interesting.

Probably would need to look at the code to see if any sections need to manually unset() variables before continuing. A lot of work went into fixing up the importers, but it might be worth looking at the installer portions.

#4 @santosj
8 years ago

Oh yeah, some installers try to manually increase the memory limit, but I don't think this would be available on shared hosts.

#5 @MichaelH
8 years ago

from this thread http://wordpress.org/support/topic/137412?replies=3

# php -version
PHP 5.0.5-2ubuntu1.8 (cli) (built: Mar 7 2007 17:13:07)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies

phpinfo() gives:
PHP Version 5.0.5-2ubuntu1.8

#6 @DD32
8 years ago

See This ticket/changeset:

(In [6681]) Increase memory limit. Props darkdragon. see #3141

It attempst to increase the memory_limit to 32M for 2.4/2.5 if possible, Else no change is made.

#7 @DD32
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Actually, Closing as duplicate of #3141 as they both deal with the 8MB memory limit.

#8 @DD32
8 years ago

  • Milestone 2.6 deleted
  • Version 2.3 deleted
Note: See TracTickets for help on using tickets.