WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 5 weeks ago

#51650 closed enhancement (duplicate)

Store file size in attachment metadata

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: needs-patch needs-unit-tests
Focuses: performance Cc:

Description

Many popular plugins like Yoast, ACF and Jetpack, use the function filesize to get the file size of a attachment. This call can be expensive. WordPress should store this file size in post meta where plugins and WordPress core can easily receive this information.

Change History (2)

#1 @davidbaumwald
5 weeks ago

  • Focuses performance added

#2 @SergeyBiryukov
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #49412.

Note: See TracTickets for help on using tickets.